Find the answer to your Linux question:
Results 1 to 2 of 2
I boot from the pendrive (or from a partition of the HDD) and I enter GRUB. The problem is that the following command line: kernel (hd0,0)/boot/vmlinuz ... root=/dev/sde doesn't always ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    40

    GRUB issue


    I boot from the pendrive (or from a partition of the HDD) and I enter GRUB. The problem is that the following command line:

    kernel (hd0,0)/boot/vmlinuz ... root=/dev/sde

    doesn't always work! That's because the pendrive is not recognized always as sde. It seems to depend on how many serial devices there are in the system. So if there are 2 SATA disks the pendrive will be the third. Each time one uses the pendrive to boot, must change the root=/dev/sde string. Is there possible to automate this or just make it more user-friendly?

  2. #2
    Just Joined!
    Join Date
    Nov 2005
    Posts
    9

    Try modifying GRUB

    I am just shooting here a little bit, but why don't you have a look at your GRUB.config file and take a close look at how you are booting into Linux.
    You didn't mention if your two SATA drives are RAID configured. I am going to assume they are not RAID configured and you have independent devices and there are no other partitions like logical ones other than /Swap and /Root.

    SATA1 drive (non-RAID configured):

    I assume /Root is located on /dev/sda1 (grub = sd0)
    I assume /Swap is located on /dev/sda2 (grub = sd1)

    SATA2 drive (non-RAID configured):

    I assume this is /dev/sdb1 (grub = sd2)

    Then, if you add a pendrive, guess what? You have three devices but four partitions....right?

    Pendrive:

    I assume this is: /dev/sdc1 (grub = sd3)

    If I am thinking right then, you really have four partitions, including the /swap
    partition, and you can fix the grub bootloader to give you a SECOND option which you will only use when you have the pen drive installed....

    Check your grub bootloader and try to add a second boot condition so that:

    1). Booting from /dev/sda1 (grub = sd0) when no pendrive used
    2). Booting from /dev/sdc1 (grub = sd3) when the pendrive used

    Of course, make a backup copy of grub before modifying it.

    I hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •