Find the answer to your Linux question:
Results 1 to 2 of 2
I'm having issues with my r8169 realtek semiconductor ethernet NIC after downgrading from the x86_64 to x86 version of Archlinux r8169's module loads with no issues however a new device ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    27

    Ethernet device not detected


    I'm having issues with my r8169 realtek semiconductor ethernet NIC after downgrading from the x86_64 to x86 version of Archlinux

    r8169's module loads with no issues however a new device is not created (iv tried restarting /etc/rc.d/network as well)

    dmesg dosnt show anything when it loads

    dmesg lists eth0 as using eth1934 and there is not eth1

    on startup right after setting irq latency timer on the device dmesg says



    Code:
    pcie_portdrv_probe->DEV[blah:blah] has invalid irq, check vendor bios.
    sorry its not an exact message, the computers are a good distance apart.

    everthing loaded automagically with arch64

    help would be appreciated, its pretty important that this machine is up and running by monday.



    not sure if this is related but ACPI is reporting on startup

    Code:
    ACPI: Looking for DSDT in initramfs... error: /DSDT.aml not found


    Thank You.

  2. #2
    Linux User cheesecake42's Avatar
    Join Date
    Jan 2007
    Location
    Orlando, FL
    Posts
    370
    i'm not entirely sure, but that first error message you listed sounded like it's talking about the video card (pcie and bios) but I could be wrong. Have you tried manually installing vendor drivers from realtek?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •