Find the answer to your Linux question:
Results 1 to 2 of 2
I can't get my sound to work. I've read the sound how-to but it only confused me. First of all, I dual boot my system but BOTH OS's are the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    15

    Sound (Very Confused)


    I can't get my sound to work. I've read the sound how-to but it only confused me.
    First of all, I dual boot my system but BOTH OS's are the same version of Debian.
    (for learning/testing purposes). The first (master) installation I had it install EVERYTHING. That installation plays sound. But the second (slave) installation I installed the minimum. That one won't play sound. The reason I'm confused is because in the how-to it says check the dmesg for sound card detection. The one that does NOT play sound shows that A sound card WAS detected. But installation that does play sound shows no evidence of detecting a sound card.

    Any ideas where to start?

  2. #2
    Just Joined!
    Join Date
    Mar 2007
    Posts
    15
    Administrators: This post is not a bump - look at the times

    Here is something i just found. Pay special attention
    to the "soundcore" field. There may be others that don't match. But just from sound of "soundCORE" I'm guessing that's
    my problem. The only thing is I have no idea what this stuff
    means or have any idea how to fix it.

    lsmod from WORKING installation
    Code:
    Module                  Size  Used by
    pcspkr                  3816  0 
    snd_intel8x0           33068  0 
    snd_ac97_codec         59268  1 snd_intel8x0
    snd_pcm_oss            48168  0 
    snd_mixer_oss          16640  1 snd_pcm_oss
    snd_pcm                85384  2 snd_intel8x0,snd_pcm_oss
    snd_timer              23300  1 snd_pcm
    snd_page_alloc         11144  2 snd_intel8x0,snd_pcm
    gameport                4736  2 analog,snd_intel8x0
    snd_mpu401_uart         7296  1 snd_intel8x0
    snd_rawmidi            23204  1 snd_mpu401_uart
    snd_seq_device          7944  1 snd_rawmidi
    snd                    50660  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
    soundcore               9824  1 snd
    lsmod from installation the does NOT play sound
    Code:
    snd_pcm_oss            48168  0
    snd_mixer_oss          16640  1 snd_pcm_oss
    pcspkr                  3816  0
    snd_intel8x0           33068  0
    snd_ac97_codec         59268  1 snd_intel8x0
    snd_pcm                85384  2 snd_pcm_oss,snd_intel8x0
    snd_timer              23300  1 snd_pcm
    snd_page_alloc         11144  2 snd_intel8x0,snd_pcm
    gameport                4736  2 analog,snd_intel8x0
    snd_mpu401_uart         7296  1 snd_intel8x0
    snd_rawmidi            23204  1 snd_mpu401_uart
    snd_seq_device          7944  1 snd_rawmidi
    snd                    50660  9 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
    i810_audio             33300  0
    ac97_codec             16908  1 i810_audio
    soundcore               9824  2 snd,i810_audio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •