Find the answer to your Linux question:
Results 1 to 6 of 6
ok its official.. i have done it... first i tried mem= 128M option. got a general protection fault.. so i decide to continue with 64 mb ram... now the download ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Location
    Mumbai, India
    Posts
    28

    I have destroyed my system ... HELP


    ok its official.. i have done it...
    first i tried mem= 128M option. got a general protection fault..
    so i decide to continue with 64 mb ram...
    now the download was big.. so i decided to check out my linux install disks..
    in disk 2 i found a folder /Preview/RPMS and SRPMS

    now here i found a kernel 2.4.0-0.26_i686.rpm
    unsatusfuied dependency : devfsd

    so i look around and find devfsd 2.4.xx but that requires kernel > 2.3.xx
    (mine is 2.2.16-22)

    so i thought .. what the hell.. and i force installed devfsd ( Big Mistake .. Maybe) and so i could insstall the kernel...

    now thew troubles begin..
    i rebooted only to see my lilo loader stop at LIL-
    so i put in my install disk and ran an upgrade... installed all the kernels i could find.. enterprise smb and stuff. and a lot more..

    so i booted backk and i was back on my 2.2.16-22 . by then i realised that i had to update my lilo with my current kernel...
    so once again.. i tried the same..
    this time.. i edited my lilo entry through linux conf to say image = /boot/vmlinuz 2.2.16-22 to /boot/vmlinuz 2.4.0-0.26
    else all the same..

    and so my box booted but then there goes everything else...
    my usb controller didnt satart.. cannot find /lib/modules/some module
    my sound didnt start - same problem
    and my fat32 drives... a whole lot of them didnt get automounted.. some incorrect minor number...

    setup to the rescue...

    my current condition..
    my kernel is back to 2.2.16-26
    i have recovered my usb controller...
    i can configure sound using sndconfig
    i cannot still mount any of my drives..
    and my mem is still 64 mb


    now all i can say is.... HELP...

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The most efficient way to make sure it works is to download the latest kernel source: ftp://ftp.kernel.org/pub/linux/kerne...2.4.20.tar.bz2. Now that is a 27 MB download, though, so I'm not sure that you'll like the idea.
    If you decide to do it, read the Kernel-HOWTO on tldp.org.

  3. #3
    Just Joined!
    Join Date
    Mar 2003
    Location
    Mumbai, India
    Posts
    28
    ty dolda...

    lets see if i can get a newer kernel.. i ll just buy the latest distro... would be much cheaper...

    however for now... i do have the system running..

    how do i mount my other partitions.. the ones it gives incorrect minor number...
    have i screwed up my fat tables??

    cause now i am under win 2k server and i can access these partitions.. and they do contain a lot of required files

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    No, you haven't screwed anything permenently. Just give the exact error message that you get when you're mounting the drives and I'll try to help.

  5. #5
    Just Joined!
    Join Date
    Mar 2003
    Location
    Mumbai, India
    Posts
    28
    hey all.. sorry for the daly in posting.. i was just looking at some stuff and i found out that it was actually a problem of devfsd that i had installed for installing kernel 2.4.0-0.26 now i am back to kernel 2.2.16-22( sucks i know...) and i guess im happy..

    things seem ok now..

    incidentally i installed kde2 a pre release i guess,, so is linux trying to look more like windows,,,, but frankly... i love the support for scroll mouse..

  6. #6
    Just Joined!
    Join Date
    Mar 2003
    Location
    Mumbai, India
    Posts
    28
    hey all.. sorry for the daly in posting.. i was just looking at some stuff and i found out that it was actually a problem of devfsd that i had installed for installing kernel 2.4.0-0.26 now i am back to kernel 2.2.16-22( sucks i know...) and i guess im happy..

    things seem ok now..

    incidentally i installed kde2 a pre release i guess,, so is linux trying to look more like windows,,,, but frankly... i love the support for scroll mouse..

    thanx guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •