Find the answer to your Linux question:
Results 1 to 3 of 3
HP Pavilion dv6226us loaded with vista well, I liked SuSE 10.1 apart from no volume control so having read other posts where the problem was resolved in HP laptops similar ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52

    grub error 22 & vista


    HP Pavilion dv6226us loaded with vista
    well, I liked SuSE 10.1 apart from no volume control so having read other posts where the problem was resolved in HP laptops similar to mine by installing 10.2 I decided to try that. I wiped out my partitions from the windows side using computer management console, except for my windows C:, it's recovery partition and my little 5 GB FAT that I used for both SuSE and Windoze. Now when I put in the SuSE 10.2 disk to install it I get a code 22 error and it won't let me do or type anything.
    So far I have:
    1) tried using the Vista recovery disk which will only allow me to completely reformat, no fix option available.
    2) Tried using an old Windoze ME disk to see if it would let me get to a command line and type fixmbr. It won't, it just gives the same error of grub loading stage 1.5 error code 22.
    3) found my bios settings, but didn't see anything useful there, it loads CD rom first then hard drive.
    4) put a knoppix live cd in, which WILL boot, but I don't know how to use it to get rid of grub.

    I want to get rid of the grub so I can install SuSE 10.2 I need to get rid of the grub right? I just want to try to get SuSE 10.2 on.

    I'm on dial up using a borrowed computer, so if I don't have to download any huge files, that would be good...

  2. #2
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52

    cd boot files didn't work

    I downloaded both the Win 98 and WinME boot disks and put them on a usb drive, tried both, both said "invalid system disk".
    I don't understand why this is happening. When I deleted SuSE before to try Fedora and then deleted Fedora the same way (through deleting the partitions on the windows side) this didn't happen. But I can't boot into windows at all, and Suse is gone...boot disks aren't working...

  3. #3
    Just Joined! savvy_cowgirl's Avatar
    Join Date
    Mar 2007
    Posts
    52
    Devil's Casper! You're fabulous!
    I tried everything else, someone got me a SuperGrub Download and it worked!!
    I can now boot into Vista!
    So now I will try again to get SuSE 10.2 on!
    That SuperGrub is the only thing I could get to work with my Vista infested lappy...
    Thank You so much.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •