I've downloaded and compiled the shiny-new 2.6.0 stable kernel. It works like a charm, except for my modem. I have a PCTel HSP56 Micromodem that won't work in any way with this new kernel. It worked perfectly under 2.4.22 (the last kernel I had installed) with the last PCTel Linux drivers around (0.9.6). But now with all the changes of the new kernel, it won't compile.

Please someone tell me where can i get PCTel driver for 2.6 kernel??