Find the answer to your Linux question:
Results 1 to 5 of 5
i had a problem when i deleted linux, the linux was installed on a slave harddisk and the GRUB loader was installed on the main partition c:, after formatting the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    Amman/Jordan
    Posts
    5

    GRUB Problem


    i had a problem when i deleted linux, the linux was installed on a slave harddisk and the GRUB loader was installed on the main partition c:, after formatting the slave partition to delete linux, now when the compter boot up, a GRUB command line appears and i cant reach to windows 98.
    How can i delete the GRUB loader?
    thanx

  2. #2
    don
    don is offline
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    101
    since ur using win98, there is not a lot u can do except run the win98 setup again.i dont think win98 comes with any fix mbr utilities and i believe you would not have backed up ur mbr prior to installation. IF u did u can restore it using a utility called restorrb. Tht should be present in dosutils folder of ur install disks( unless my information is outdated )
    I\'m just a simple fisherman blessed with a lot of friends

  3. #3
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Use you Windows 98 bootdisk.
    At the dos prompt run : fdisk /mbr
    And grub is gone.

    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    Ontario, GTA
    Posts
    14
    You need to restore the MBR, like Opnosforatou said.

    a WIN98 Boot disk, or possibly the cd will have a utility on it to do this.

  6. #5
    Just Joined!
    Join Date
    Jun 2004
    Location
    pittsburgh
    Posts
    3

    there is a simple resolution:)

    resolution:
    >> go to the BIOS setting before you start your OS.
    >> check you hard drives and change the type of detection the primary hd, AUTO to LBA.
    >> and save it, and reboot.

    you will see your windows is working now.

    this problem is that GRUB doesnot correspond with some BIOS, so it doesnt not get the right partition table. which means it skips the first /dev/hda1 --> windows partition(LBA). GRUB starts to read the table from the second partition, /dev/hda2 or /dev/hdb1--> might be /boot of your linux distribution.

    try it. you do not need to reinstall any of your OSs and reinstall MBR.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •