Find the answer to your Linux question:
Results 1 to 8 of 8
I have just installed Windows XP Pro onto my new PC, then used Partition Magic to create three separate partitions. One for Windows at the start of the hard drive, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4

    Problem with grub booting windows


    I have just installed Windows XP Pro onto my new PC, then used Partition Magic to create three separate partitions. One for Windows at the start of the hard drive, one for fedora core 2 and a third for my shared files formatted vfat.
    I installed Fedora on the 2nd partition fine along with the grub bootloader.
    When I boot up, Fedora works fine but when choosing to boot windows it prints out:
    bootnoverify (hd0,0)
    chainloader +1
    and just sits there doing nothing.
    Is there a problem with windows or the grub bootloader?
    Help will be much appreciated.

  2. #2
    Just Joined!
    Join Date
    Oct 2003
    Location
    The Netherlands
    Posts
    89
    default=0
    timeout=20
    splashimage=(hd0,1)/boot/grub/splash.xpm.gz
    title Red Hat Linux
    root (hd0,1)
    kernel /boot/vmlinuz-2.4.20-31.9smp ro root=/dev/hda2 hdc=ide-scsi acpi=on
    initrd /boot/initrd-2.4.20-31.9smp.img
    title Windows XP
    rootnoverify (hd0,0)
    chainloader +1
    This is the content of my grub.conf file, and i have absolutely no problems with booting Windows XP.

    Did you install grub on the mbr on on the first sector of you Fedora partition?

    mine is installed on my mbr.

  3. #3
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    acollins,
    not sure that I fully understand the sequence of events that you did.

    Did you first install WinXP, and then create some more partitions, or did you create the partitions first, then install WinXP and then Linux?

    If the second, can you confirm that WinXP ran before you loaded Linux and Grub?

    And can you reconfirm that WinXP is on the first partition on the first (perhaps only) hard disk?

    Also, when you go into Linux, can you run the hardware browser (in system tools or system setup) and see what it says about the partitions on your hard drive (it should hopefully show the first partition as either NTFS or FAT, then your Linux partition, then your shared partition [by the way, have you a SWAP partition for Linux?]).
    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4
    In responcse to Lepricaun -

    My grub.conf file looks exactly the same as the one you have shown. I think I installed grub on the MBR but I am unsure. I think I'll just start all over again and get it right this time!!!

    In response to Nerderello -

    I firstly installed Windows on it's own on the hard drive, then resized it's partition and created two new ones in the free space after it. I then installed linux on the second partition. All of the partitions where formatted as their sprecific formats when I created them using Partition Magic.

    I have already tried looking at the hardware browser in linux and it showed all of the partitions as I expected to see them formatted as I expected (Windows being NTFS, Linux being ext2 and my shared drive being vfat).

    About the swap partition. I didn't create one because I read somewhere that Fedora Core 2 doesn't have to have a swap partition. Does a swap partition have any benefits?

    Thankyou for all of your replies. They are greatly appreciated. I think I'm just going to start from scratch again and be a bit more careful.

  6. #5
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4
    OK. I've decided to start from scratch again by putting in the Windows XP disc and reinstalling it on top of everything. But after the first phase of installation it reboots and gets the error 'problem loading operating system".
    Has linux done anything to my PC's hard drive which means I can't install windows? I've tried loading up the recovery console and using 'fixmbr' to get rid of grub but it doesn;t help???
    Please help.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    There's nothing that Linux can do to your hard drive that would disallow Windows from installing on it.

    This probably isn't what you want to hear, but it sounds to me like you got a problem with a damaged hard drive. I can't know that for sure, but it does seem like it.

  8. #7
    Just Joined!
    Join Date
    Jun 2004
    Posts
    1

    WinXP problems after FC2 install

    Here is a link which describes your issue, as well as a resolution. Apparently a bug in the FC2 installation...

    http://lwn.net/Articles/86835/

    Good luck with the recovery!

  9. #8
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4
    I've sorted the problem. I read on another forum somewhere that changing the Hard Drive from Auto to LBA in the BIOS might sort out the problem and let me install XP from scratch.

    So I set it to LBA, put in the Xp disc and installed Windows without a hitch without the 'error loading operating system' I had previously.

    I created a partition for XP when installing it leaving enough free space for core 2.

    Then I installed core 2 with grub on the mbr. It now all works fine.

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •