Find the answer to your Linux question:
Results 1 to 6 of 6
I am currently running Red Had 9 (Shrike) with kernel 2.4.20.8. I downloaded and then tried to compile the 2.6.6 kernel. I compiled them using the following steps, 1. Extract ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    Compiling kernel 2.6.6 in RH-9


    I am currently running Red Had 9 (Shrike) with kernel 2.4.20.8. I downloaded and then tried to compile the 2.6.6 kernel. I compiled them using the following steps,
    1. Extract the kernel contents
    2. open terminal and then change directory to the kernel source directory
    3. make menuconfig
    4. make bzImage
    5. make modules
    6. make modules_install
    7. make install

    after I installed the kernel, I rebooted the system. I am using the GRUB loader. The new kernel entry appeared in the loader properly, but I get the message during the booting process of the new kernel. It states the following.

    VFS: cannot open root device "LABEL=/" or unknown-block (0,0)
    please append a correct "root=" boot option
    kernel panic : VFS : Unable to mount root fs on unknown-block (0,0)
    <7> uhci-hcd 0000:00:1d.0 suspend_hc

    what does this mean? suggest me a solution.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yeah, RedHat uses those disklabel things, which I've never seen work on a vanilla kernel. Personally, I don't understand why they're still using those disklabels, since they always seem to be causing trouble for everyone.

    What you want to do instead is pass the actual device name to the kernel - that is, instead of using root=LABEL=/ in your grub.conf, replace that with root=/dev/hda1 or wherever your root filesystem resides.

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    but I tried it

    Thanks for the reply. I don't know anything about those LABELS and what they mean, but as you had said I had tried that option also before posting that message on the forum. The problem is still persisting. Please help me resolve it.

  4. #4
    don
    don is offline
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    101
    well as for ur kernel, i think 2.6 kernels compile with just a make and a make install. Have u enabled support for devfs in your kernel configuration. 2.4 kernels require devfs while i think its deprecated in 2.6 kernels. However your distro could still require it to function. Other things to look out for would be if u have ewnabled support for your current file system.
    I\'m just a simple fisherman blessed with a lot of friends

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    No kernel requires devfs - only distros require it, and I for one would never use a distro that requires it. ;-)
    In any case, RedHat doesn't want devfs.

    Did you compile the IDE driver as a module or built-in to the kernel? The same question for the filesystem driver of your root filesystem. They should be built-in, or you'll need an initrd. If they are indeed built-in, can you post the exact error message you get when you try and use root=/dev/hdxx instead? It shouldn't read exactly the same as the one you posted above.

  6. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    Thanks a lot...

    At last the kernel worked fine when I removed the option "ro root=...LABEL..." stuff from the boot loader.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •