Find the answer to your Linux question:
Results 1 to 2 of 2
Hi. I've been trying to get linux running well on my macbook pro (pre september 2006) am trying to install a custom kernel to provide hardware support for the smc ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    15

    Question initramfs ?


    Hi.
    I've been trying to get linux running well on my macbook pro (pre september 2006) am trying to install a custom kernel to provide hardware support for the smc, keyboard, touchpad, graphics, and other drivers.

    Compilation and installation are no problem: used a vanilla kernel and grabbed a copy of the current config from /boot. I use the "make-kpkg" and "dpkg -i" to compile and install the kernel (respectively). However, when I reboot into my custom kernel, the boot stops after this:

    Begin: Running /scripts/local-premount
    resume libgcrypt version 1.2.4

    I then get a message that says:

    Could not stat the resume device '/dev/sda3'
    Please type in the full path name to try again or press ENTER to boot the system.

    Hitting ENTER lands me in an initramfs system and .... I'm stuck. I have no idea what's going or how to get my system to boot.

    Here are the kernels I've tried:
    • 2.6.18-4-686 (debian default, works perfectly because I didn't compile it )
    • vanilla 2.6.18.4 (compiled with the /boot/config-2.6.18-4-686 and the .config and used "make oldconfig" to configure. Then it was "fakeroot make-kpkg --initrd kernel_image" to build and "sudo dpkg -i" to install. Had no problems with booting this one.)
    • vanilla 2.6.18.4 (same as above but this time I actually set some of the options. No problem)
    • vanilla 2.6.20.15 (same as above. Unbootable)
    • vanilla 2.6.22 (same as above)



    Any ideas, explanations, comments, etc?


    Edit:
    I've found some info on the ramfs idea, but am still nowhere further. I've got initramfs-tool installed, and I did a reinstallation of them through aptitude, but still no luck.
    Last edited by aliaseer; 08-15-2007 at 09:44 PM. Reason: found some more info

  2. #2
    Just Joined!
    Join Date
    Mar 2009
    Posts
    1
    Sorry, I know it's too late for the answer, but I was having the same problems today with Debian Lenny and I found this post in first google position, so I'll post the answer here so that more people could solve this problem

    Just do this:
    Code:
    # update-initramfs -u -k 2.6.28
    Where 2.6.28 is the new kernel you want to use.

    I don't know if it's correct or not, but I also made the same changes to the current kernel:
    Code:
    $ uname -r
    2.6.22-1-686
    
    # update-initramfs -u -k 2.6.22-1-686
    PD: I have a white MacBook.
    Hope it helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •