Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, New computer Centos 5.0 with all updates. Kernel version: 2.6.18-8.1.14.el5. Hdd: WD800JD. Show somethnig like below and hanging up. Time to hangup is different sometimes 2h, sometimes 6h. What ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1

    HDD or motherboard error ?


    Hello,

    New computer Centos 5.0 with all updates. Kernel version: 2.6.18-8.1.14.el5. Hdd: WD800JD. Show somethnig like below and hanging up. Time to hangup is different sometimes 2h, sometimes 6h.

    What could create this problem ?


    ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
    ata2.00: (BMDMA stat 0x4)
    ata2.00: tag 0 cmd 0xca Emask 0x4 stat 0x40 err 0x0 (timeout)
    ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata2: soft resetting port
    ata2.00: qc timeout (cmd 0xec)
    ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata2.00: revalidation failed (errno=-5)
    ata2: failed to recover some devices, retrying in 5 secs
    ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata2: soft resetting port
    ata2.00: qc timeout (cmd 0xec)
    ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata2.00: revalidation failed (errno=-5)
    ata2: failed to recover some devices, retrying in 5 secs
    ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    ata2: soft resetting port
    ata2.00: qc timeout (cmd 0xec)
    ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata2.00: revalidation failed (errno=-5)
    ata2.00: disabled
    ata2: EH complete
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 14757703
    Buffer I/O error on device sda1, logical block 1844705
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 177287
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 177319
    Buffer I/O error on device sda1, logical block 22157
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 14696615
    Buffer I/O error on device sda1, logical block 1837069
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 14751927
    Buffer I/O error on device sda1, logical block 1843983
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 14757703
    Buffer I/O error on device sda1, logical block 1844705
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 43257487
    Buffer I/O error on device sda1, logical block 5407178
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 43258567
    Buffer I/O error on device sda1, logical block 5407313
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 47186063
    Buffer I/O error on device sda1, logical block 5898250
    lost page write due to I/O error on sda1
    Aborting journal on device sda1.
    journal commit I/O error
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 14751823
    Buffer I/O error on device sda1, logical block 1843970
    lost page write due to I/O error on sda1
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 14751927
    Buffer I/O error on device sda1, logical block 1843983
    lost page write due to I/O error on sda1
    ext3_abort called.
    EXT3-fs error (device sda1): ext3_journal_start_sb: Detected aborted journal
    Remounting filesystem read-only
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 71
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505103
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505231
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505287
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505375
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505391
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505447
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505495
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 5505543

  2. #2
    Just Joined!
    Join Date
    May 2008
    Posts
    1
    I have what looks to be the same problem . Also running Centos 5, and it hangs after 4 hr. on average. I tried putting in a new SATA hd, then a new power supply, neither worked. I read on another forum that someone changed a BIOS setting to not allow 64 bit PCI I/O mapping above 4G and that seemed to fix the problem, but I dont think that I want to change that setting. Does anyone have any other fix or at least an explanation as to why this is screwing up?

    section of dmesg report:

    ata2: soft resetting port
    ATA: abnormal status 0x7F on port 0x9C07
    ATA: abnormal status 0x7F on port 0x9C07
    ata2.00: qc timeout (cmd 0xef)
    ata2.00: failed to set xfermode (err_mask=0x4)
    ata2.00: limiting speed to UDMA/100
    ata2: failed to recover some devices, retrying in 5 secs
    ata2: soft resetting port
    ATA: abnormal status 0x7F on port 0x9C07
    ATA: abnormal status 0x7F on port 0x9C07
    ata2.00: qc timeout (cmd 0xef)
    ata2.00: failed to set xfermode (err_mask=0x4)
    ata2.00: limiting speed to PIO0
    ata2: failed to recover some devices, retrying in 5 secs
    ata2: soft resetting port
    ATA: abnormal status 0x7F on port 0x9C07
    ATA: abnormal status 0x7F on port 0x9C07
    ata2.00: qc timeout (cmd 0xef)
    ata2.00: failed to set xfermode (err_mask=0x4)
    ata2.00: disabled
    ata2: EH complete
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 8048970
    sd 1:0:0:0: SCSI error: return code = 0x00040000
    end_request: I/O error, dev sda, sector 8048986
    Buffer I/O error on device sda5, logical block 4061
    lost page write due to I/O error on sda5
    Aborting journal on device sda5.
    EXT3-fs error (device sda5) in ext3_reserve_inode_write: Journal has
    aborted
    sda : READ CAPACITY failed.
    sda : status=0, message=00, host=4, driver=00
    sda : sense not available.
    sda: Write Protect is off
    sda: Mode Sense: 00 00 00 00
    sda: asking for cache data failed
    sda: assuming drive cache: write through
    EXT3-fs error (device sda5) in ext3_reserve_inode_write: Journal has
    aborted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •