Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all i use slackware 10 with kernel(2.4.26)(default).Yesterday i compiled kernel 2.6.7 (source) from the slackware cd2 i compiled it all gone ok and then i boot my new system ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Greece
    Posts
    187

    kernel 2.6.7 sound


    Hi all i use slackware 10 with kernel(2.4.26)(default).Yesterday i compiled kernel 2.6.7 (source) from the slackware cd2 i compiled it all gone ok and then i boot my new system alll seemed to be ok and when i log into X i get the message /dev/dsp device not found even if the modules for my soundcard are loaded ok.So i run alsaconf it recognize my soundcard via 82xx onboard and then when i try to run alsamixer i get the message :
    [code]
    alsamixer: function snd_ctl_open failed for default: No such file or directory
    and so all the others audio mix applications don't run.
    Any help?

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Make sure you update your alsamixer/alsatools/etc. I'm not sure what else it could be...
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    53
    I was having the same problems. But I upgraded my kernel using the package included on the cd. My problem was that I hadn't had the right modules loaded I guess.

    But I now find myself in a different situation with sound. All the sound modules seem to load properly, but when I run alsamixer it says, "no mixer elems found."

    Quote Originally Posted by sarumont
    Make sure you update your alsamixer/alsatools/etc. I'm not sure what else it could be...
    How might one go about doing that?

    Any help is appreciated.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    How to do that depends on what distro you're using.

  5. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    6
    Dear all,
    try typing alsaconf in console

    Appleman1234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •