I'm fairly new to the Linux word wrt System Management. We have an IBM xSeries 345 server and I want to install the latest SCSI device driver. It's running RedHat ES V3 (I think).

/root> uname -a
Linux xxx.yyy.zzz 2.4.21-47.0.1.ELsmp #1 SMP Fri Oct 13 17:56:20 EDT 2006 i686 i686 i386 GNU/Linux

I downloaded the driver from IBM's web-site into /tmp/ which consists of a .img file and a .rpm file.

aic79xx-2.0.13-1.rhel3qu3.i686.img
aic79xx-2.0.13-1.rhel3qu3.i686.rpm

I tried installing the package with rpm -ivh aic79xx-2.0.13-1.rhel3qu3.i686.rpm and got:

Code:
Preparing...                ##################################################
aic79xx                     ##################################################
kernel_type=2.4
We have something to do !!

Adaptec aic79xx driver installer - V2.0.13-1

Options: do_mkinitrd=1 do_lilo=1 root dir=
Modifying /etc/modules.conf

Backing up all modified files to /boot/aic79xx-backup-1

alias scsi_hostadapter1 aic79xx
Using GRUB configuration
If this is not what you want, rename your /boot/grub/grub.conf file
/boot
-rw-r--r--    1 root     root       350975 Apr  7  2006 initrd-2.4.21-37.ELsmp.img

/boot/vmlinuz-2.4.21-37.ELsmp /boot/initrd-2.4.21-37.ELsmp.img Red Hat Enterprise Linux ES (2.4.21-37.ELsmp)
Configuration [Red Hat Enterprise Linux ES (2.4.21-37.ELsmp)]
label=Red Hat Enterprise Linux ES (2.4.21-37.ELsmp) image=/boot/vmlinuz-2.4.21-37.ELsmp version=[2.4.21-37.ELsmp] initrd=/boot/initrd-2.4.21-37.ELsmp.img
/boot/vmlinuz-2.4.21-37.ELsmp -> 2.4.21-37.ELsmp
Installing Module...
Checking for prebuilt 2.4.21-37.ELsmp-i686.
Looking for aic79xx-2.4.21-37.ELsmp-i686
Checking for prebuilt 2.4.21-37.ELsmp-i586.
Looking for aic79xx-2.4.21-37.ELsmp-i586
Checking for prebuilt 2.4.21-37.ELsmp-i386.
Looking for aic79xx-2.4.21-37.ELsmp-i386
Checking for prebuilt 2.4.21-37.ELsmp-ia32.
Looking for aic79xx-2.4.21-37.ELsmp-ia32

****** PROBLEM *******
No prebuilt module for 2.4.21-37.ELsmp i686
**********************
/boot
-rw-r--r--    1 root     root       474156 Jan 31  2007 initrd-2.4.21-47.0.1.EL.img
This repeats 3 times.

So, what am I doing wrong.

Thanks,
Vic