Find the answer to your Linux question:
Results 1 to 2 of 2
Ok, this is strange. I recently upgraded (from source) from 2.6.18 to 2.6.24. Everything seems to work OK (finally), except... whenever I launch an application for the first time, it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4

    Applications slow to startup after upgrade to 2.6.24.2


    Ok, this is strange. I recently upgraded (from source) from 2.6.18 to 2.6.24. Everything seems to work OK (finally), except... whenever I launch an application for the first time, it loads s l o w l y. After that, the same app launches painlessly (so, presumedly, it's being brought into a cache, made memory-resident, something).

    I didn't observe this behavior in 2.6.18. Is anybody aware of some new 2.6.24 feature that might cause this type of behavior? Has this happened to anybody else?

    Thanks.

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by jdaviestx View Post
    Ok, this is strange. I recently upgraded (from source) from 2.6.18 to 2.6.24. Everything seems to work OK (finally), except... whenever I launch an application for the first time, it loads s l o w l y. After that, the same app launches painlessly (so, presumedly, it's being brought into a cache, made memory-resident, something).

    I didn't observe this behavior in 2.6.18. Is anybody aware of some new 2.6.24 feature that might cause this type of behavior? Has this happened to anybody else?

    Thanks.
    For some people (including me) the CFS task (not i/o) scheduler, seems responsible for some responsiveness (interactivity) problems. But it shouldn't be related to your problem, if the only thing you noticed is longer startup times.

    Maybe you disabled your chipset driver and so you are using non-dma transfers on your hd's? You only have to worry about that on IDE drives, so, if you use SATA that's not it. Or maybe it is just some placebo effect.

    EDIT: Just in case, you might want to try recompiling your kernel after you turn this option off:

    Code:
    [ ] Fair group CPU scheduler
    That's under the general settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •