Find the answer to your Linux question:
Results 1 to 4 of 4
Julian Coccia | blog I used this article to install linux on a compact flash...as per the article i have copied /boot/* to the flash(including vmlinuz and grub.conf)...i m using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    2

    Problem booting from compact flash (kernel panic)


    Julian Coccia | blog

    I used this article to install linux on a compact flash...as per the article i have copied /boot/* to the flash(including vmlinuz and grub.conf)...i m using fedora 7 and my grub.conf looks like this :



    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,6)
    # kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
    # initrd /initrd-version.img
    #boot=/dev/sda
    default=1
    timeout=10
    splashimage=(hd0,6)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora (2.6.21-1.3194.fc7)
    root (hd0,6)
    kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    initrd /initrd-2.6.21-1.3194.fc7.img
    title Windows XP
    rootnoverify (hd0,0)
    chainloader +1


    Also,when booted i get GRUB command line as given in the article...i executed these commands..

    GRUB> root (hd0,0)
    GRUB> kernel /boot/vmlinuz root=/dev/hda1 rw init=/bin/sh
    GRUB> boot

    Following the boot command..vmlinuz opens and then a few steps later i encounter the following error:
    cannot mount on root=/dev/hda1
    append the correct "root="boot option
    kernel panic:cannot mount vfs

    Can someone correct me,where i m going wrong...is it required to modify the grub.conf file?Or should i give "root=" some other device?...is there any other website that gives detailed procedure to deploy linux on the compact flash?...help required urgently...Thank you in advance

  2. #2
    Linux Newbie
    Join Date
    Mar 2008
    Location
    Hyderabad
    Posts
    109
    You have installed on compact flash?
    Might be you should device name /dev/disk or whatsoever is the name of flash drive on you linux, check in /dev directory.
    GRUB> kernel /boot/vmlinuz root=/dev/disk rw init=/bin/sh
    instead of
    GRUB> kernel /boot/vmlinuz root=/dev/hda1 rw init=/bin/sh

  3. #3
    Just Joined!
    Join Date
    Mar 2008
    Posts
    2

    Thank you replying

    I tried it and it didnt work....If u see, i have used Julian Coccia | blog procedure, wherein i have created only four devices(hda,hdb,hdc,hdd) under dev of the compact flash...so there is no disk directory as in the case of /dev of fedora7...shud i create more devices to boot correctly from cf??

  4. #4
    Linux Newbie
    Join Date
    Mar 2008
    Location
    Hyderabad
    Posts
    109
    I tried the same procedure and 'm getting the same results.
    Kernel Panic
    But another screen message is maximum stack depth used 5126 bytes remaining.
    My flash drive is 1 GB only i do think the kernel we have used occupies greater space than what we have in flash.
    I used 2.6.24.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •