Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all I read that at first system loads the code at the MBR and then the rest of the loader. what I cant understand is how it can read ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4

    Boot process question


    Hi all
    I read that at first system loads the code at the MBR and then the rest of the loader.
    what I cant understand is how it can read that although the scsi driver has not yet been loaded neither the root partition has been mounted.

    what I have in mind is the following :
    system needs os
    os is on a disk
    to read the disk we need driver
    the driver is on the disk
    !!!
    can someone help me
    thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Go through this article. If you have any confusion/question, do post back.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    4
    Dear Casper,
    my problem arose when I tried to boot linux redhat 4U4 from SAN
    I the installation goes well but after rebooting it gives me an I O error, like if it doesn't see the LUN. I tried to understand why I can install on disk but cant boot from.
    thanks

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •