Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I'm not sure if this is the right forum, but here goes anyway... I have an existing small disk image with an old Linux 2.4 kernel and nuni boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    127

    My compiled kernel image doesn't work


    Hi,
    I'm not sure if this is the right forum, but here goes anyway...

    I have an existing small disk image with an old Linux 2.4 kernel and nuni boot loader. I'm trying to upgrade the kernel to the latest stable kernel 2.6.24.4, so I downloaded and compiled it. I used knoppix's .config file rather than a make xconfig to make things simple. I then did a make bzImage, which gave me the bzImage file in arch/x86/boot/bzImage, which is 2.7MB. I got nuni to use this image file instead, but when I tested the disk image, it doesn't boot up.

    I tried using other kernel versions, such as vmlinuz-2.6.22.9-desktop-1mdv from my own Mandriva 08 installation, and it worked, so I'm inclined to think that something went wrong with my compilation, even though no errors were reported?

    Does anyone know what might be wrong? TIA.

  2. #2
    Linux Newbie athlon_crazy's Avatar
    Join Date
    Sep 2007
    Location
    Malaysia
    Posts
    132
    after make bzImage, make module && make modules_install?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •