Find the answer to your Linux question:
Results 1 to 2 of 2
I have a problem with a engine-driver that is connected via usb2serial adapter to a usb port on an Acer laptop. The thing is that sometimes, the engine-driver gives a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    1

    Question How to stop USB hotpluging?


    I have a problem with a engine-driver that is connected via usb2serial adapter to a usb port on an Acer laptop. The thing is that sometimes, the engine-driver gives a signal that the ehci_hcd (the kernel) interprets like a disconnection followed by a new connection. So the kernel remounts the device in a new ttyUSB# and all my programs that are accessing to the device hung.
    I thought that if I could stop, at executing time, the hotplug feature from the usb modules, the problem will be concluded.
    Does anybody know if there is any way to stop hotpluging? I don't know perhaps in any flags from /sys/ filesystem...
    My kernel version is 2.6.23.17 in a Fedora Core 7.

    Thanks in advance,
    J

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    5
    You can stop the service which takes care of the hotplugging. I believe it would be autofs on my Fedora.

    But in a simpler way, through the menu System > Preferences > Hardware > Removable Drives and Media, you can uncheck one of the 'Mount removable media' options according to your liking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •