Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unhappy linux on powerpc booting problem

    Hi folks,

    i am trying to port linux on the Virtex IIpro XUP board from Xilinx.

    i am using ppc405

    i downloaded the linux source from,setup the cross compiler and finally i could get a zImage in my hand. i am using device tree - fdt.dts - which is generated by the EDK10.1 and i copied this to kernel source..

    i downloaded the bit file to the fpga , and using xmd i downloaded the zImage to DDR SDRAM. when i run , i get the following lines on the tty:

    booting virtex
    zImage starting: loaded at 0x00400000 (sp: 0x00578f1c)
    Allocating 0x326564 bytes for kernel ...
    gunzipping (0x00000000 <- 0x0040c000:0x005772bb)...done 0x3015c8 bytes
    Linux/PowerPC load: console=ttyS0 ip=on root=/dev/ram
    Finalizing device tree... flat tree at 0x40ad68

    It doesnt proceed after the above line. anyone has any idea what could be the problem



  2. #2
    I also do some linux+ppc development and I remember to booting
    problems mainly to dead console.

    Few things/questions come to my mind.
    1. just for info what kind of bootloader do you use (uboot in my case)?

    2. do you use correct device for console? I mean did you try also another
    devices like ttyS1...?

    3. This question might be strange but when you get dead console does the
    machine automatically reboot after some time? If yes then maybe you have
    you have just specified bad device.


  3. #3
    thanks for the reply.
    i am not using any bootloader, but use xmd to download the zImage to the SDRAM. im getting output from the bootwrapper part of the image, but not from the vmlinuz(x) part.
    i have only one console, ie, ttyS0. kernel boot arguments(in menuconfig) for the console has been given with the baud rate 9600(same as my device).

    the machine is not rebooting,but stuck at some point..

    i am using custom device tree file for the kernel. the dts file is attached..

    Attached Files Attached Files

  4. $spacer_open
  5. #4
    I still think that there is just something wrong with boot console but I can be wrong.
    I found the following link regarding booting so maybe would check this:

    Fix booting of Xilinx FPGAs with 16550 for 405 and 440


  6. #5

    It worked,but....

    YUP..!!! my system is up, but....
    the problem was with the EDK. EDK10.1 is not supported xup design directly..
    when i tried the same design with 9.1 it worked fine..

    No i got up to the shell. but no response from the shell do u have any idea on this..??!!

    bootlog as follows:

    reeing initrd memory: 1471k freed
    msgmni has been set to 503
    io scheduler noop registered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered (default)
    Generic non-volatile memory driver v1.1
    40600000.serial: ttyUL0 at MMIO 0x40600003 (irq = 16) is a uartlite
    brd: module loaded
    loop: module loaded
    mice: PS/2 mouse device common for all mice
    i2c /dev entries driver
    RAMDISK: Compressed image found at block 0
    VFS: Mounted root (ext2 filesystem) readonly.
    Freeing unused kernel memory
    ifconfig: socket: Function not implemented
    /etc/mtab: cannot create
    ### Application running ...

  7. #6
    If I understand you well then you can't get shell prompt on console but can you login
    via telnet?
    Anyway excerpt from your post this looks like a prompt shell:
    ### Application running ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts