Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    installing recompiled kernel using GRUB error: ata.piix....

    I am using fedora core 2. İnstalled from the iso cd images and recompiled the kernel (2.6.5-1.35 to support ntfs filesystems. This all worked well but I downloaded the new kernel source recompiled, installed modules and tried to install the new kernel with the "make install " command this is the error message I get
    "[root@localhost linux-]# make install
    make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
    CHK include/linux/compile.h
    Kernel: arch/i386/boot/bzImage is ready
    sh /usr/src/linux- arch/i386/boot/bzImage ""
    No module ata_piix found for kernel, aborting.
    mkinitrd failed
    make[1]: *** [install] Error 1
    make: *** [install] Error 2

    After this message in the /boot directory the initrd.*.ımg file is missing.
    I tried to use the "mkinitrd" command manually as well and also edited the grub.conf file and tried to boot withot the ramdisk option but no luck. How can I solve this problem.

  2. #2
    Try to install ATA_PIIX as module. How did you get this new kernel? From RHN with FF2 up2dates? If so, try to download the kernel from Running 2.6.5 you can use oldconfig to configure the new one, this will save you a lot of work.

  3. #3
    thanks , but I could not find the ata.piix driver and also didin't know how to install . But I found another solution. I used to "make clean" before "make modules" "make modules_install" "make install" I guess this make clean erased the installed ata.piix drivered. BUt then I tried without the "make clean" command , it works now. The reason I changed the FFC compiled original kernel was that it did not have ntfs support. I need to access my windoz partition. Thank you for your time anyway.

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts