Find the answer to your Linux question:
Results 1 to 9 of 9
I'm trying to compile a linux kernel for a powerpc ( MPC5200B ). I already have a prebuilt kernel running on this. So I built a cross compiler with buildroot. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    5

    Compiling linux for powerpc


    I'm trying to compile a linux kernel for a powerpc (MPC5200B).

    I already have a prebuilt kernel running on this.

    So I built a cross compiler with buildroot. I correctly set the 'Target Architecture' and 'Target Architecture Variant' to powerpc, 603e.

    Then I downloaded a linux kernel source and real time linux patch. Extract, patch, edit makefile for cross compiling.
    As config I used the mpc5200_defconfig, 52xx/lite5200b_defconfig and the config from the prebuilt kernel.
    In the first two configs I only changed the PREEMPT_RT so the kernel would be real time.
    Lets compile: make uImage
    Builds without errors.

    The board has U-boot running as bootloader on it.
    I have successfully booted the prebuild kernel with this bootloader.
    But when I try to boot my own kernel it just says nothing and it reboots.

    The prebuilt kernel is booted with a 'Flattened Device Tree', when I give this same file to my kernel it still does the same.

    I already tried a different cross compiler, ELDK.
    The bootloader prints 'uncompressing kernel... ok' after that,
    depending on my boot options, 'Booting using flat device tree at <address>' after this it just waits for a few seconds and then reboots.

    What is going wrong here?


    Ingmar Blonk

  2. #2
    Just Joined!
    Join Date
    Sep 2008
    Posts
    25
    ... and how do your kernel options look like?
    What version the pre-build kernel is (2.4 or 2.6)?

    Regards,
    ndevel.

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    5
    Quote Originally Posted by ndevel View Post
    ... and how do your kernel options look like?
    What version the pre-build kernel is (2.4 or 2.6)?

    Regards,
    ndevel.
    The prebuild kernel version is 2.6.24-rt1, and I'm trying to compile 2.6.26.5-rt9.

    I already tried to compile the 2.6.24-rt1 version with the prebuild kernel config, but that one didn't work either. So I think I need some patch or something.

    With kernel options you mean config?
    If so, what do you want to know, guess that I shouldn't post the config file just here...

  4. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    25
    sorry for misunderstanding...
    ...by kernel options I mean arguments which are given to kernel by uboot during startup.
    I definitely don't mean your config file.

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    5
    I pass the option 'console=ttyPSC0,115200' to the kernel and some options for the nfs-root, but that doesn't matter because the kernel doesn't get there.

  6. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    25
    no idea for now but maybe you should try to boot without RT patch first.

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    5
    I already tried to do that, but still the same error (actually none, because we don't get output).

  8. #8
    Just Joined!
    Join Date
    Sep 2008
    Posts
    5
    did you mention "console=..." in bootargs in the device tree file you pass on to the kernel..??

  9. #9
    Just Joined!
    Join Date
    Sep 2008
    Posts
    5
    I don't exactly know, but I guess it is in the pre-build device tree file, because the pre-build device tree file is using the same console= bootargs.

    But that can't be the reason that the kernel reboots. Otherwise it would just hang without saying something.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •