Find the answer to your Linux question:
Results 1 to 3 of 3
I wasn't quite sure where to put this, so please move if in wrong place. Thank you. I installed Ubuntu-server 7.10 on my virtual machine last night (VirtualBox-ose). The install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310

    [SOLVED] VirtualBox-ose error message during OS boot


    I wasn't quite sure where to put this, so please move if in wrong place. Thank you.

    I installed Ubuntu-server 7.10 on my virtual machine last night (VirtualBox-ose). The install went fine. After the LiveCD was removed from the cd tray, I booted into Ubuntu-server via my virtual machine normally; or at least I tried to. I got a Panic error that said:

    Panic: CPU too old for this Kernel
    WTF?? Anyway, I did some research and kind of made some progress on identifying my problem. The first page I read (Bug #151942) said it was a VirtualBox-ose problem because the VM doesn't support a PAE Kernel. Well, while reading through that page, I came to this page (Guest PAE - ticket #212 CLOSED: fixed) where I learned that it was not a problem with VirtualBox-ose, but rather a problem with the Ubuntu Installer. Someone said that the Ubuntu installer loads from a non-PAE Kernel and then tries to install as/on a PAE Kernel without testing it first. (Which would explain why the LiveCD and install worked, but the program couldn't boot from the install itself.) This page appears to fix the problem, but I am having trouble identifying the fix.

    I am still doing more research while stuck at school. Any input from any of you would be much appreciated.

    For an explanation of what what a PAE Kernel is, see here.

    Thank you!

    SkittleLinux18
    Last edited by SkittleLinux18; 09-22-2008 at 09:12 PM. Reason: Additional Links
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

  2. #2
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310
    Will a moderator please insert [SOLVED] into the thread title, please? Thank you.

    Here is how to solve this problem:

    1) boot from the Ubuntu-server LiveCD and select "Rescue a Computer" from the GRUB menu.

    2) Run through the CLI installer/recovery mode process and follow any and all instructions on screen.

    3) when prompted to, select the option to run a shell on a partition. Mine was /mnt/sda1

    4) You'll drop down into a command prompt. Execute this command:

    apt-get install linux-generic
    5) reboot the virtual machine normally and everything should be good to go.
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hi, Skittle

    Thanks for returning to post the fix.

    Just so you'll know, users can mark their own threads SOLVED now by clicking the "thread tools" link at the top of each thread.

    I'll handle this one for you.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •