Find the answer to your Linux question:
Results 1 to 4 of 4
Hi! I have compiled the 2.6.8.1 kernel on a partition running reiserfs. However, i get the kernel panic: no init found every time i start it. I don't get any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    4

    Kernel Panic: No init found.. Ive tried everything!!


    Hi!
    I have compiled the 2.6.8.1 kernel on a partition running reiserfs. However, i get the kernel panic: no init found every time i start it. I don't get any other messages before and it mounts the harddisk and mounts devfs on /dev. And the .conf file is from CRUX so it dont need a initrd, and i have copy the whole /etc folder and the /sbin/init file from crux, and it still dont work. I also tried append="init=/sbin/init" in lilo.conf

    Thanks in regard.

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Location
    Bahrain
    Posts
    12
    hi
    listen my friend this problem happened to me onetime

    if you are using GDM login manager enter the to KDE from
    root the use the shell to configure and compile your kernel
    after u finnish all steps open this windows

    we used KDE because it is the easiest way ..

    before configuring and compiling the image i suggest to extart ur kernel in the dir /usr/src


    then enter this dir
    /usr/src/NEWKERNEL/arch/i386/boot

    then open a new window to dir of ur boot partition (e.g /boot)
    then drag the file (bzImage) from this dir
    /usr/src/NEWKERNEL/arch/i386/boot
    into ur boot partition (e.g /boot)

    then i small list will come choose link this file

    the finall step is start LILO config application in configuration --> KDE -->
    System ---> LILO boot manager

    run the application then press on New Kernel
    the copy all configuration of you default kernel into the new one but dont copy init box , leave it blank then press on Make it default after that press on OK

    you should not have any warning message then reboot
    and everything will be OK

    if anything comes wrong tell me i will help u

    bye now

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    4
    Ok, thanks, but ive copied bzImage and moved it to /vmlinuz. That was were i did when i build crux... but i'll try with a link, is it ln to do that, since i dont have X in crux...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7
    Here's an excelent kernel compiling tutorial: http://www.linuxquestions.org/questi...rnel+compiling
    If u follow these instructions the only thing it can go wrong are your kernel setings

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •