Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm a Debian user, and I've installed via apt-get (aptitude, in fact) the package called kernel-image-2.6.8-1-k7. I've edited my lilo.conf to look like this: image=/boot/vmlinuz-2.6.8-1-k7 label="New Linux" initrd=/boot/initrd.img-2.6.8-1-k7 And ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1

    Problems with kernel-image-2.6.8-1-k7


    Hi,

    I'm a Debian user, and I've installed via apt-get (aptitude, in fact) the package called kernel-image-2.6.8-1-k7. I've edited my lilo.conf to look like this:

    image=/boot/vmlinuz-2.6.8-1-k7
    label="New Linux"
    initrd=/boot/initrd.img-2.6.8-1-k7

    And then I ran lilo, with no problems. My computer is an Athlon Thunderbird 1.33ghz, running smoothly on the Knoppix 2.4 kernel (installed to hdd and modified since).

    On reboot, I could select the new kernel in the lilo menu, and then I got the "Loading Linux.................................." screen with all the dots. And then the screen blanked out, and that was that. Just black, nothing else.

    Same goes for the package which ends with -1-386, tried that too, editing the lilo.conf accordingly, but no luck. I also know that apt-get is supposed to edit lilo.conf for me automagically, but for some reason it doesn't happen here (even though I say "Yes" when it aska during the installation).

    Any clue? How do I move my box to 2.6 successfully?

    I also tried compiling, btw, but it was a ton of work and I couldn't make it work right...

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Me too

    HI,
    Me too, although updated via synaptic. The screen just locks on loading kernel (k7).
    However I was able to reboot and navigate down to 386, luckily.

    However unsure from here how to fix it.

    I would be everly grateful if anyone could shed some light and help?

    Thanks very much

    S

  3. #3
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624
    Quote Originally Posted by simoneb
    Please do not hijack a thread . Post a new one if this thread's answers do not help you.
    I think you will need to compile the kernel and set proper options before you can boot into it. Make sure that you are using the correct kernel image and initrd when you put it onto lilo/grub. To compile the kernel:
    Code:
    # cd /usr/src
    # ln -s <location of unpacked kernel dir> linux
    # cd linux
    # make xconfig (or make menuconfig)
    # make dep && make clean vmlinux modules modules_install
    # cp arch/i386/boot/vmlinuz /boot/testimage
    Now edit your lilo to include an entry for this testimage. Try booting into it.

    Note that compiling the kernel is a very time consuming excercise but has excellent rewards (moves you up on the learning curve ). Use lspci -v -v to get some help.
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Smile Thanks

    HI,
    Thanks ever so much, I will have a go, thanks again for your help.

    I may get back to you with any probs though.

    Thanks again.

    All the very best
    S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •