Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I'm trying to update the kernel in 1 of my drives from 2.6.22.19 to the latest stable 2.6.27.7 release. It seems that some changes happened. First, there's arch/i386/boot has ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128

    How to change root_dev for kernel 2.6.27.7?


    Hi,

    I'm trying to update the kernel in 1 of my drives from 2.6.22.19 to the latest stable 2.6.27.7 release. It seems that some changes happened.

    First, there's arch/i386/boot has been replaced by arch/x86/boot. Also the boot sector file bootsect no longer exists, and the build command's syntax has changed to reflect this.

    I have previously been able to build an uncompressed kernel whose rootdev is /dev/sda1 with the following script:

    Code:
    echo "Builds uncompressed Image here with root device as /dev/sda1"
    mknod  /dev/sda1 b 8 1
    objcopy -O binary -R .note -R .comment -S vmlinux tmppiggy
    cd arch/i386/boot
    tools/build -b bootsect setup ../../../tmppiggy /dev/sda1 > ../../../Image_sda
    cd -
    echo "The uncompressed image can only boot from /dev/sda1 and is called Image_sda"
    However, I'm unable to do this even after changing the directory names, because the file "setup" doesn't exist. How do I change the rootdev then?

  2. #2
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    OK, I ended changing ROOT_DEV in arch/x86/boot/Makefile from CURRENT to "/dev/sda1" and the when I do a "file bzImage" it gives the following output:
    Code:
    bzImage: Linux kernel x86 boot executable RO-rootFS, root_dev 0x801, swap_dev 0x1, Normal VGA
    This is however different from my other 2.6.22.19 kernel that has its rootdev changed with the "build" command:
    Code:
    bzImage: Linux kernel x86 boot executable RO-rootFS, root_dev 0x801, swap_dev 0x2, Normal VGA
    The swap_dev is different.

    I've tried booting up to the new kernel image from a few systems and there are some systems that won't boot up from it. It boots up with the following message and then kernel panics:
    Code:
    VFS: Cannot open root device "801" or unknown-block (8,1)
    Please append a correct "root=" boot option; here are the available partitions:
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)
    The only difference I can see between the 2 images is the swap_dev. What could be wrong?

  3. #3
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    anyone has any clue?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    Can anyone help?

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    South West England
    Posts
    91
    Silly question, Have you set "root=/dev/sda1" in the append options? That's all I can think of.

  7. #6
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    128
    Thanks for the help. I didn't set it under the append option in lilo.conf, but I did set it as a separate line.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •