Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    The gcc 2.95.3 Catch-22 Problem

    In trying to read everything that is is applicable, and heed all the proper advice for compiling a new kernel with newly selected options [not to mention the scary case of actually trying to modify a loadable module--just baby steps first], you eventually get here:


    and you read:

    Kernel compilation


    The gcc version requirements may vary depending on the type of CPU in your
    computer. The next paragraph applies to users of x86 CPUs, but not
    necessarily to users of other CPUs. Users of other CPUs should obtain
    information about their gcc version requirements from another source.

    The recommended compiler for the kernel is gcc 2.95.x (x >= 3), and it
    should be used when you need absolute stability. You may use gcc 3.0.x
    instead if you wish, although it may cause problems. Later versions of gcc
    have not received much testing for Linux kernel compilation, and there are
    almost certainly bugs (mainly, but not exclusively, in the kernel) that
    will need to be fixed in order to use these compilers.
    So, now you start looking for ways to get a hold of a downloadable set of executables and their version-related libraries. The cygwin folks seem to be happy with moving way ahead to more current versions of gcc and I don't even want to think of what problems I would cause myself by obtaining the 2.95.3 RPM sources and trying to compile them with the current compiler that comes with the nice/complete SuSE 9.1 Pro distribution.

    Can someone resurrect the required down-level compiler and provide some installation instructions as to how to configure your environment to sometimes compile with 2.95.3 and sometimes compile with the current 3.3.3. executables and libraries [or any other dependencies that I have not even considered]? Otherwise, how is kernel recompilation ever to be correctly performed if the proper verison of the compiler cannot be installed?

    Thank you.

  2. #2
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    South- or "Mid-" Sweden
    I'd say that you should use the most recent ("stable") gcc you can get, I've compiled all of my kernels with gcc v3.3.x, and I've not yet had an gcc caused compile error (more like "wrong choices for my arch"-options, living on the edge by fooling around with the flags in the make file, etc).
    The worst thing that probably could happens is that you boot in to the new kernel and it panics (sort of equivalent to window's BSOD - with out the options "crash now", "try to crash afain" ), just reboot in in to the old kernel then.
    Regards Scienitca (registered user #335819 - )
    A master is nothing more than a student who knows something of which he can teach to other students.

  3. #3
    I have had no problems compiling with gcc 3.3.x, and more recently, gcc 3.4.2.

    You should be able to install a seperate gcc toolset in a different location. For example, download the newest gcc sources, and configure with --prefix=/usr/local/gcc-3.4.2. When you wish to use that toolset, specify that you wish to use it when configuring applications for a build.

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts