Find the answer to your Linux question:
Results 1 to 3 of 3
I am running FC2 and I upgraded the kernel a couple of weeks ago (from 2.6.5-1.358 to 2.6.8-1.521). Now when I power on my computer, I am presented a choice ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    GNU GRUB - selecting default boot kernel


    I am running FC2 and I upgraded the kernel a couple of weeks ago (from 2.6.5-1.358 to 2.6.8-1.521). Now when I power on my computer, I am presented a choice of which kernel to boot, with the default selection being the older kernel. What do I need to do to make the newer kernel the default boot selection? Thanks!

  2. #2
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    At the top (or in some of the firs line) in your /etc/grub.conf you might already have a line that looks someting like this:
    Code:
    default 0
    Just change the number 0 to the number of the boot-options as they are presented in the /etc/grub.conf. But remember that the first boot option has number 0 and the second has number 1 and so on.
    If you don't have this line you can add it at the top of the /etc/grub.conf -file.

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    That took care of it! Thanks much for your enlightenment!!!

    SL

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •