Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, I want to generate a periodic interrupt through RTC. However, /dev/rtc file doesnt exist. How can i configure the kernel to enable the RTC. Thanks....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    5

    /dev/rtc doesnt exist


    Hello,
    I want to generate a periodic interrupt through RTC. However, /dev/rtc file doesnt exist. How can i configure the kernel to enable the RTC. Thanks.

  2. #2
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    Which kernel/platform are you using?
    To create your rtc device, find the description of your device and use the following command:
    mknod /dev/rtc c [major number] [minor number]

  3. #3
    Just Joined!
    Join Date
    Jul 2009
    Posts
    5
    Thanks for the reply.
    I am using Ts-linux.
    I tried what you suggested and here what I got:
    [root@epc dev]#mknod /dev/rtc c [10] [135]
    mknod: invalid major device number `[10]'

    One of the sites was suggesting the following:
    "modprobe: Can't locate module char-major-10-135

    char-major-10-135 refers to the character device, major 10, minor 135, which is /dev/rtc. It provides access to the BIOS clock, or RTC, the Real Time Clock. See /usr/src/linux/Documentation/rtc.txt for more information.

    The error is because something, most likely hwclock, is trying to use /dev/rtc but you haven't configured kernel support for it in your kernel. Either delete /dev/rtc so hwclock won't try to use it or enable RTC support in your kernel. It's located in make menuconfig under "Character devices" -> "Enhanced Real Time Clock Support"."

    how can i get to menuconfig. Is there a way to enable RTC through terminal line because my TS-linux platform has no GUI (its a platform for a PC104 computer).

    thanks

  4. #4
    Just Joined!
    Join Date
    Jul 2009
    Posts
    5
    How can i enable the RTC in kernel. I am a beginner in linux

  5. #5
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    The RTC is enabled with make menuconfig. To have graphic view, you must install ncurse on your PC.

  6. #6
    Just Joined!
    Join Date
    Jul 2009
    Posts
    5
    Quote Originally Posted by lynxx View Post
    The RTC is enabled with make menuconfig. To have graphic view, you must install ncurse on your PC.
    i there a way to enable it from the terminal line?

  7. #7
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    on your linux directory, you can find and edit a ".config" file containning the configuration done by the "make menuconfig" menu. Seek the string "RTC" and decomments the line and add "=y" instead of "is not set".

  8. #8
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    Editing .config file directly is strongly discouraged. By doing make menuconfig all internal dependencies are maintained - and this is something you want.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •