Find the answer to your Linux question:
Results 1 to 2 of 2
This is my first time posting here. Hopefully there is someone who can point me in the right direction with this issue. I have been running kernel 2.6.26.8 for some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    2

    Real Time Kernel and SMP Folding at home client


    This is my first time posting here. Hopefully there is someone who can point me in the right direction with this issue.

    I have been running kernel 2.6.26.8 for some time now, patched with Ingo Molnar's Real-Time Preemption patch rt-13.

    The machine is an Opteron-185 CPU running Xubuntu 9.04. The machine is a dedicated folding at home rig, running the current SMP client.

    This week I decided it was long enough on teh old kernel and built a new one on 2.6.29.6, patched in the same way with the rt-23 kernel patch. I imported the same .config that was used in the prior version. On my first build, everything seemed to be OK until I started the folding client. Only one core engaged. I ran menuconfig again, checking to make sure that all SMP options were selected. AFAICT, all were ok. In the next two days I tried selecting several different options that I thought could be causing the problem, and built three more kernel attempts, each failing to run the SMP client with more than one core.

    I tried another build using the 2.6.29.6 kernel, and DID NOT patch it with the RT patch. This build ran the client fine. So the problem lies with the RT kernel patch configuration, but where?

    For brevity, the process was like this:
    -start machine, loading kernel 2.6.26.8-rt13 patched: WU runs OK [running this way for months now]
    -build new 2.6.29.6 vanilla [no patch];install new kernel
    -reboot and load kernel 2.6.29.6 vanilla: WU runs OK
    -patch 2.6.29.6 with rt23 and build; install new kernel
    -reboot into kernel 2.6.29.6-rt23 patched; WU runs one core only.

    It seems that I have failed to check some obscure option (perhaps a new one) in the new kernel build, breaking SMP somehow. Is there anyone out there with some idea where I can check for this option, perhaps with knowledge of the RT kernel?

    Thanks to anyone who can help.

  2. #2
    Just Joined!
    Join Date
    Aug 2009
    Posts
    2
    To continue this saga, I have now experimented with both 2.6.30 and 2.6.31 with the same results. All vanilla kernel builds work fine; but every kernel version since 2.6.26.8, when patched with the RT patch, fail to run both cores using the very same .config file to build them.

    I do not know how or where to report this, and it may be some sort of bug, not with the kernel itself, but with the Real Time kernel development. Can anyone point me in the right direction?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •