Find the answer to your Linux question:
Results 1 to 3 of 3
I compiled my own kernel, and my kern.log and syslog files are filling up with networking logging messages such as the following: Code: Oct 8 14:32:48 server kernel: [619790.164937] ''IN-world':'IN=eth0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    43

    Getting Rid of Unnecessary Logging


    I compiled my own kernel, and my kern.log and syslog files are filling up with networking logging messages such as the following:

    Code:
    Oct  8 14:32:48 server kernel: [619790.164937] ''IN-world':'IN=eth0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:24:1d:8f:e1:97:08:00 SRC=192.168.0.102 DST=255.255.255.255 LEN=116 TOS=0x00 PREC=0x00 TTL=64 ID=52511 PROTO=UDP SPT=1035 DPT=19540 LEN=96
    I guess my first question is, are these necessary? And my second question is, if not, how do I get rid of them? I'm thinking it is some kernel option, but I can't seem to find it.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,574
    Did you compile a debuggable version of the kernel?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    43
    Not that I know of. However, I found a way to turn the logging off. I'll look it up in case anyone else is looking for the same answer.

    I added the following "kern.!warning" to the rsyslog.conf file, so that the following lines looked like this:

    Code:
    *.*;auth,authpriv.none,kern.!warning	-/var/log/syslog
    kern.*;kern.!warning				-/var/log/kern.log
    That got rid of the warnings that were filling up my logs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •