Hi all,

I am trying to install "gtk-2.10.0" in my target board based on ARM architecture. I had installed glib-2.10.0, pango, cairo, Atk...
I have exported the variables PKG_CONFIG_PATH=/opt/gtk/lib/pkgconfig and LD_LIBRARY_PATH=/opt/gtk/lib

when i tried to configure, i got the below error.
#./configure --prefix=/opt/gtk
checking for HP-UX... no
checking for extra flags for POSIX compliance... none needed
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.12.0...
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.16.5)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.12.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

please help me out of this problem.
thanks in advance,