Find the answer to your Linux question:
Results 1 to 3 of 3
I haven't upgraded my kernel in rather a long time, and the distribution (fc6) is EOL'd, so I've been trying to compile a new one. I started with latest stable ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    2

    Question [SOLVED] kernel upgrade woes


    I haven't upgraded my kernel in rather a long time, and the distribution (fc6) is EOL'd, so I've been trying to compile a new one. I started with latest stable (2.6.32.3), built and installed it, but booting failed, so I stepped back to 2.6.22.19 as my best guess at the optimal near-match to my current 2.6.22.14-72.fc6.

    I used oldconfig with my current config, then:
    Code:
    make V=1 bzImage
    make V=1 modules
    sudo make V=1 modules_install
    sudo cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.22.19
    sudo cp System.map /boot/System.map-2.6.22.19
    sudo /sbin/mkinitrd -f -v /boot/initrd-2.6.22.19.img 2.6.22.19
    # add to grub.conf:
    title Handrolled (2.6.22.19)
            root (hd0,0)
            kernel /boot/vmlinuz-2.6.22.19 ro root=LABEL=/
            initrd /boot/initrd-2.6.22.19.img
    When booting with this, I get:
    Code:
    Loading ata_piix.ko module
    ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
    ACPI: PCI Interrupt 0000:00:1f.2[b] -> GSI 19 (level, low) -> IRQ 19
    ata_piix 0000:00:1f.2: 0x1F0 IDE port busy
    ata_piix 0000:00:1f.2: 0x170 IDE port busy
    ata_piix 0000:00:1f.2: no available legacy port
    Trying to resume from LABEL=SWAP-sda2
    No suspend signature on swap, not resuming.
    Creating root device.
    Mounting root filesystem.
    ext3: No journal on filesystem on hdd5
    mount: error mounting /dev/root on /sysroot as ext3: Invalid argument
    Setting up other filesystems
    Setting up new root fs
    setuproot: moving /dev failed: No such file or directory
    no fstab.sys, mounting internal defaults
    setuproot: error mounting /proc: No such file or directory
    setuproot: error mounting /sys: No such file or directory
    Switching to new root and running init.
    unmounting old /dev
    unmounting old /proc
    unmounting old /sys
    switchroot: mount failed: No such file or directory
    Kernel panic - not syncing: Attempted to kill init!
    I'm not sure the ext3 message is relevant - hdd5 is an old disk usually mounted readonly as /old, the boot disk is sda.

    Any suggestions of what to try next, or how to go about diagnosing the problem? I've scanned the config diffs (attached), and can't see an obvious culprit - they are all removals of presumably obsolete variables; I've also checked that the initrd contains the same entries as my current one, and the init script is identical.

    Hugo
    Attached Files Attached Files
    Last edited by Hugo_vdS; 01-14-2010 at 02:06 PM. Reason: solved

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    you'd probably spend less time installing and configuring the latest fedora than you would trying to get a new kernel to work on an old distro

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    2
    Got this working, finally, thanks to some great help from Greg at my old office.

    Not sure exactly why, but with the new build the IDE driver gets to see the SATA disk before the SATA driver does: I should have searched for the first thing that looked like an error message ("no available legacy port") to find answers more quickly.

    The solution is to tell the IDE driver not to attempt to detect drives on the first controller, by adding "ide0=noprobe" to the kernel command line.

    That doesn't yet solve things for the 2.6.32.3 build, but now I have a reproducible baseline at 2.6.22.19 I should be able to take it forward.

    Hugo

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •