I have tried compiling my own kernel, version 2.6.32.7 from kernel.org. I ran a defconfig and then selected options from menuconfig. After compiling the kernel it booted just fine on my Ubuntu 8.04 system, but when I try to login into GNOME it just stalls for over a minute and after that whatever I try to do takes forever. TTY/commandline works just fine.

I tested with a different version of the kernel to rule out the possibilty that it was a bug in this version. And now I think I have missed a essential configuration option.

After some debugging I suspect that it is something with the networking that causes it. I can't access anything on my local network, not even ping it. I can't even ping my own computer/localhost. Whatever I do it just stalls waiting forever. However, DHCP worked just fine (plugging out the cable and it does not). Also ARP works just fine (I get arp-responses with the correct MAC-addresses). And whenever I try to do something else the leds on the switch flashes.

Any ideas?