Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, This is my first post in this forum - I hope I am in the right place. Here is the issue that I am facing. On my computer ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Location
    France
    Posts
    2

    USB mass storage disconnected randomly (due to EMI?).


    Hi all,

    This is my first post in this forum - I hope I am in the right place.
    Here is the issue that I am facing.

    On my computer (than runs 24/7), an USB mass storage is connected and sometimes (randomly, about once every 3 days) it is disconnected due to some EMI issues...

    At boot time, the device is mounted as /dev/sda1 :


    Feb 24 10:09:28 localhost kernel: Initializing USB Mass Storage driver...
    Feb 24 10:09:28 localhost kernel: scsi0 : SCSI emulation for USB Mass Storage devices
    Feb 24 10:09:28 localhost kernel: usbcore: registered new interface driver usb-storage
    Feb 24 10:09:28 localhost kernel: USB Mass Storage support registered.
    Feb 24 10:09:28 localhost kernel: usb-storage: device found at 2
    Feb 24 10:09:28 localhost kernel: usb-storage: waiting for device to settle before scanning
    Feb 24 10:09:28 localhost kernel: scsi 0:0:0:0: Direct-Access SAMSUNG HM500JI PQ: 0 ANSI: 2 CCS
    Feb 24 10:09:28 localhost kernel: usb-storage: device scan complete
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/465 GiB)
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] Write Protect is off
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] Mode Sense: 34 00 00 00
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
    Feb 24 10:09:28 localhost kernel: sda: sda1
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
    Feb 24 10:09:28 localhost kernel: sd 0:0:0:0: [sda] Attached SCSI disk
    Then, without changing anything, it is disconnected and reconnected as /dev/sdb1 (by udev, I guess ?) :

    Mar 1 00:09:50 localhost kernel: hub 1-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
    Mar 1 00:09:50 localhost kernel: usb 1-1: USB disconnect, address 2
    Mar 1 00:09:51 localhost kernel: EXT2-fs error (device sda1): ext2_get_inode: unable to read inode block - inode=1384455, block=5537794
    Mar 1 00:09:51 localhost kernel: usb 1-1: new full speed USB device using s3c2410-ohci and address 3
    Mar 1 00:09:51 localhost kernel: usb 1-1: configuration #1 chosen from 1 choice
    Mar 1 00:09:51 localhost kernel: scsi1 : SCSI emulation for USB Mass Storage devices
    Mar 1 00:09:52 localhost kernel: usb-storage: device found at 3
    Mar 1 00:09:52 localhost kernel: usb-storage: waiting for device to settle before scanning
    Mar 1 00:09:52 localhost kernel: EXT2-fs error (device sda1): ext2_get_inode: unable to read inode block - inode=1384504, block=5537797
    Mar 1 00:09:57 localhost kernel: scsi 1:0:0:0: Direct-Access SAMSUNG HM500JI PQ: 0 ANSI: 2 CCS
    Mar 1 00:09:57 localhost kernel: EXT2-fs error (device sda1): ext2_get_inode: unable to read inode block - inode=1384504, block=5537797
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] 976773168 512-byte logical blocks: (500 GB/465 GiB)
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] Write Protect is off
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] Mode Sense: 34 00 00 00
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] Assuming drive cache: write through
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] Assuming drive cache: write through
    Mar 1 00:09:57 localhost kernel: sdb: sdb1
    Mar 1 00:09:57 localhost kernel: usb-storage: device scan complete
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] Assuming drive cache: write through
    Mar 1 00:09:57 localhost kernel: sd 1:0:0:0: [sdb] Attached SCSI disk
    Mar 1 00:10:02 localhost kernel: EXT2-fs error (device sda1): ext2_get_inode: unable to read inode block - inode=1384504, block=5537797
    The main consequence is that data on the hard drive is not accessible anymore.
    I need to unmount and remount the device manually.

    Here is the corresponding line in fstab :

    UUID="d1529615-5f0e-42d0-837e-b354e5872d32" /media/disk/ ext2 defaults 0 0
    Here is my kernel :
    Linux artichaut 2.6.32-rc8 #4 Mon Jan 25 00:05:23 CET 2010 armv4tl GNU/Linux
    As my computer runs as a server, how can I deal with such an issue ?
    I think I can not get rid of the EMI issue (?). But I would like that, when it occurs, the hard drive is properly reconnected and mounted.
    Another solution could be ignoring this temporary disconnection as I know that the USB hard drive will be connected all the time.

    Thanks,

    Julien

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Label the volume with the tune2fs tool and use the label in /etc/fstab instead of the device name. IE, LABEL=vol-name instead of /dev/sda1
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Location
    France
    Posts
    2
    Thanks for replying, Rubberman.

    Currently, I do not use the device name in my /etc/fstab but the UUID :

    UUID="d1529615-5f0e-42d0-837e-b354e5872d32" /media/disk/ ext2 defaults 0 0
    So, do you think that using a label instead of the UUID could change anything ?

    I could make a try, anyway.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Labels are preferable to UUID's since they are transferable between systems. However, loss of connectivity will still require that you remount the device. You can use the remount option to the mount command an avoid unmounting the drive, per se.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •