Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I've a problem with compiling an patched kernel. I patched the kernel 2.6.31.8 with rtai-3.8. To patch the kernel is no problem. But even I try to compile the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    13

    [SOLVED] RTAI patched kernel compiling irq error


    Hello,

    I've a problem with compiling an patched kernel. I patched the kernel 2.6.31.8 with rtai-3.8. To patch the kernel is no problem. But even I try to compile the kernel I get this message:

    Code:
    arch/x86/kernel/ipipe.c: In function ‘__ipipe_syscall_root’:
    arch/x86/kernel/ipipe.c:852: warning: left shift count >= width of type
    arch/x86/kernel/ipipe.c:853: warning: left shift count >= width of type
    arch/x86/kernel/ipipe.c: In function ‘__ipipe_handle_irq’:
    arch/x86/kernel/ipipe.c:896: error: ‘irq_desc’ undeclared (first use in this function)
    arch/x86/kernel/ipipe.c:896: error: (Each undeclared identifier is reported only once
    arch/x86/kernel/ipipe.c:896: error: for each function it appears in.)
    arch/x86/kernel/ipipe.c: At top level:
    arch/x86/kernel/ipipe.c:1016: error: ‘irq_desc’ undeclared here (not in a function)
    arch/x86/kernel/ipipe.c:1016: warning: type defaults to ‘int’ in declaration of ‘irq_desc’
    arch/x86/kernel/ipipe.c:1032: error: ‘per_cpu__irq_stack_union’ undeclared here (not in a function)
    arch/x86/kernel/ipipe.c:1032: warning: type defaults to ‘int’ in declaration of ‘per_cpu__irq_stack_union’
    make[2]: *** [arch/x86/kernel/ipipe.o] Fehler 1
    make[1]: *** [arch/x86/kernel] Fehler 2
    make: *** [arch/x86] Fehler 2
    Could it be a problem of the properties that I use in the menuconfig?

    Regards,
    flam

  2. #2
    elh
    elh is offline
    Just Joined!
    Join Date
    Mar 2010
    Posts
    1
    Hi,

    I got the "per_cpu__irq_stack_union" undeclared error, too. I was able to avoid it by disabling CONFIG_CC_STACKPROTECTOR in kernel config ("Enable -fstack-protector buffer overflow detection" under "Processor type and features").

    And I also had to set the following:
    CONFIG_HPET_TIMER=n
    CONFIG_SPARSE_IRQ=n

    Don't know about the "irq_desc" symbol, though. I didn't got this error.

    regards
    elh

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    13
    Hello elh,

    Thank you for your help. Now it works.

    I'm also found this Instruction:
    Compile custom kernel (Linux 2.6.31. patched with RTAI (latest CVS version – vulcano) for Ubuntu (9.10) (For me its not allowed to post url's, but I think with this title it should be possible to find the manual)

    It explains how to install the newest RTAI with Ubuntu 9.10. But thats the same solution like the solution of elh. Only a little bit more detailt.


    Regards,
    Franz

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •