Find the answer to your Linux question:
Results 1 to 9 of 9
Hello, When I start my patched kernel from Ubuntu/Grub I get only a blackscreen. I get no messages about the system state. Is it possible to force linux to give ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    13

    Blackstart Screen


    Hello,

    When I start my patched kernel from Ubuntu/Grub I get only a blackscreen. I get no messages about the system state. Is it possible to force linux to give me a echo. It would be helpfull if I no witch module cause the error (of course).

    Regards,
    flam

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Are you using any option with kernel like quiet and wrong vga value?

    Post the kernel line from /boot/grub/menu.lst file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    13
    Hi,

    I haven't an menu.1st. I'm using the newest kernel. But I think the /etc/default/grub is the template for the "booting-file". Here the lines of this file:
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=2
    GRUB_HIDDEN_TIMEOUT=2
    GRUB_HIDDEN_TIMEOUT_QUIET=false
    GRUB_TIMEOUT=-1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=" splash"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entrys
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    I'm only change the Value of "GRUB_TIMEOUT" and "GRUB_HIDDEN_TIMEOUT_QUIET" so I always see the Bootloader-Menu.

    Is there anything suspect in my file?

    Regards,
    flam

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Remove quite and splash.
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT=""
    Execute update-grub command to generate new grub.cfg file. Boot up new kernel and check where it get stuck.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    13
    Hello,

    I set the value "GRUB_CMDLINE_LINUX_DEFAULT=""". So I can see some messages when I start my old kernel. But with my new kernel I see only a black screen.
    Any other ideas?

    Regards,
    flam

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which Graphics Card do you have? Does new kernel boot up in command line mode?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Mar 2010
    Posts
    13
    Hello,

    In Commandline I've the same effect. I write the commands, put enter and get (immediatly) an black screen (without any message).
    My Device Manager told me that I use an NV43GL [Auadro FX 550] from nVidia Corporation with an PCI-Connection.
    Is it possible that my patch kill the support for this card?

    Regards,
    flam

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=" splash"
    Have you removed splash keyword from GRUB_CMDLINE_LINUX=" splash" line too. Remove it and execute update-grub command again. Check the contents of /boot/grub/grub.cfg file.
    There should be any option like splash or quiet in the kernel line of new Kernel.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Nov 2008
    Posts
    5
    Do you get into GRUB? Do you get any kind of shell?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •