Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I have enabled owner match support in kernel version 2.6.35.5 through, Networking -- Networking options -- Network packet filtering framework (Netfilter) -- Core netfilter configuration -- "owner" match support ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    13

    Owner match support


    Hi,

    I have enabled owner match support in kernel version 2.6.35.5 through,

    Networking -- Networking options -- Network packet filtering framework (Netfilter) -- Core netfilter configuration -- "owner" match support

    I have compiled the kernel and rebooted, but csf is showing this error,

    ************
    iptables: Unknown error 4294967295
    Error: iptables command [/sbin/iptables -I OUTPUT -p tcp --dport 25 -m owner --uid-owner 0 -j ACCEPT] failed, at line 338
    ************

    I have found out that the ipt_owner module is not enabled in the kernel. can you help me enabling this module in the kernel?

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,763
    If you did not compile the kernel with support for this module:

    Code:
    grep -i match_owner /boot/config*
    
    CONFIG_IP_NF_MATCH_OWNER=m
    CONFIG_IP6_NF_MATCH_OWNER=m
    Then you'll need to recompile using the usual "make config" or "make menuconfig" method and select this option as a module.

    All kernel options

    NETFILTER_XT_MATCH_OWNER

  3. #3
    Just Joined!
    Join Date
    Oct 2010
    Posts
    13
    Thanks for the reply, I will check it out now....

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2010
    Posts
    13
    Quote Originally Posted by HROAdmin26 View Post
    If you did not compile the kernel with support for this module:

    Code:
    grep -i match_owner /boot/config*
    
    CONFIG_IP_NF_MATCH_OWNER=m
    CONFIG_IP6_NF_MATCH_OWNER=m
    Then you'll need to recompile using the usual "make config" or "make menuconfig" method and select this option as a module.
    I get the following from the config file.

    CONFIG_NETFILTER_XT_MATCH_OWNER=m

    Couldn't find those mentioned in your post. I tried to enable that module in that kernel, but could not find the modules. Can those be enabled by editing the .config file manually?

  6. #5
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    878
    Hit / key in menuconfig and search for it, editing config manually does not consider dependencies and is unlikely to work.

  7. #6
    Just Joined!
    Join Date
    Oct 2010
    Posts
    13
    Quote Originally Posted by Segfault View Post
    Hit / key in menuconfig and search for it, editing config manually does not consider dependencies and is unlikely to work.
    I have already done that, but it didn't help. Is these modules still in 2.6.35 version kernels since I can see only xt_owner module.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •