Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am trying to configure a kernel (2.6.35.7, under openSuSE 11.3) that would be able to use all my 4GB RAM (not just 3.5GB) but when I go to "Processor ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    S0S
    S0S is offline
    Just Joined!
    Join Date
    Oct 2010
    Posts
    5

    cannot enable High Memory Support


    I am trying to configure a kernel (2.6.35.7, under openSuSE 11.3) that would be able to use all my 4GB RAM (not just 3.5GB) but when I go to "Processor type and features" -> "Enable High Memory Support", as per the instructions on a lot of places I found by googling, the option is disabled (grayed out in gconfig, XXX in nconfig). A lot of other options are disabled too, for example, a subset of the options looks like this:

    XXX MICROCODE_OLD_INTERFACE
    <*> /Dev/cpu/*/msr - Model-specific register support
    <m> /Dev/cpu/*/cpuid - CPU information support
    XXX High Memory Support
    XXX off
    XXX 4GB
    XXX 64GB
    XXX Memory split
    XXX 3G/1G user/kernel split
    XXX 3G/1G user/kernel split (for full 1G low memory)
    XXX 2G/2G user/kernel split
    XXX 2G/2G user/kernel split (for full 2G low memory)
    XXX 1G/3G user/kernel split
    XXX () PAGE_OFFSET
    XXX HIGHMEM
    XXX PAE (Physical Address Extension) Support
    XXX ARCH_PHYS_ADDR_T_64BIT
    XXX Enable 1GB pages for kernel pagetables[*] nUma Memory Allocation and Scheduler Support
    XXX *** NUMA (Summit) requires SMP, 64GB highmem support, ACPI ***[*] Old style AMD Opteron NUMA detection[*] ACPI NUMA detection
    XXX NODES_SPAN_OTHER_NODES[*] nUMA emulation
    (9) mAximum NUMA Nodes (as a power of 2)
    XXX HAVE_ARCH_BOOTMEM
    XXX ARCH_HAVE_MEMORY_PRESENT
    XXX NEED_NODE_MEMMAP_SIZE
    XXX HAVE_ARCH_ALLOC_REMAP
    XXX ARCH_FLATMEM_ENABLE
    XXX ARCH_DISCONTIGMEM_ENABLE
    XXX ARCH_DISCONTIGMEM_DEFAULT

    I couldn't find any menu option in the config utilities to enable the XXXs.
    I also googled for "linux kernel config disabled options", but nobody seems to have had this problem.
    I guess I could just add CONFIG_HIGHMEM64G=y to .config to fix my problem in this particular case, but I'd better figure out what's wrong with my settings.

    Any ideas will be appreciated.

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,387
    I assume, you are on a 32bit system/OS

    If so: forget it.
    3.5GByte is about the maximum you will be able to use, as the system needs some of the address space for itself and the presentation of pci devices, etc.


    You could install a 64bit linux
    You must always face the curtain with a bow.

  3. #3
    S0S
    S0S is offline
    Just Joined!
    Join Date
    Oct 2010
    Posts
    5
    No, I am using the 64-bit openSuse (I have /lib64, etc., no doubt about the 64 bit capability of my system).

    I also dual boot with Windows 7 x64 which sees 3.9GB.

    Something else is wrong with my system.

  4. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,387
    Can you please do
    Code:
    uname -m
    file /bin/ls
    free
    and paste the output here?
    Last edited by Irithori; 10-07-2010 at 05:32 PM.
    You must always face the curtain with a bow.

  5. #5
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,756
    As already noted, HIGH MEMORY support has NO bearing on a 64 bit OS.

  6. #6
    S0S
    S0S is offline
    Just Joined!
    Join Date
    Oct 2010
    Posts
    5
    s0s:~ # uname -m
    x86_64
    s0s:~ # file /bin/ls
    /bin/ls: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.4, stripped
    s0s:~ # free
    total used free shared buffers cached
    Mem: 3776624 3694436 82188 0 673228 2142792
    -/+ buffers/cache: 878416 2898208
    Swap: 2867192 496 2866696
    Last edited by S0S; 10-07-2010 at 06:27 PM.

  7. #7
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    do you have integrated graphics card? some memory will be taken by OS and allocated to it

    also fwiw, you are closer to 4gb than 3.5 gb

  8. #8
    S0S
    S0S is offline
    Just Joined!
    Join Date
    Oct 2010
    Posts
    5
    3.5 was a typo, sorry for that. It is really 3.6 GB in KDE System Monitor.
    3776624 kB = 3.601 GB, so it is closer to 3.5.
    I have an integrated graphics processor in the CPU itself (Core i3 530), and in the bios i can set it to 32, 64, or 128 MB. I think currently it is set to 128MB.

    So this cannot explain the whole difference. I know that PCI devices take up some of the memory, but Windows sees about 300 MB more.

    So now there are two questions - why the options are grayed out, and can I utilize more of my memory.
    Last edited by S0S; 10-07-2010 at 06:40 PM.

  9. #9
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,756
    As already noted, HIGH MEMORY support has NO bearing on a 64 bit OS.
    As already noted, HIGH MEMORY support has NO bearing on a 64 bit OS.

  10. #10
    S0S
    S0S is offline
    Just Joined!
    Join Date
    Oct 2010
    Posts
    5
    @HROAdmin26:

    I just read the article you linked to and, although I see it is written for 32 OSes, I'm not sure what to make of it for a 64 bit OS. It does not say that HIGH MEMORY support has NO bearing on a 64 bit OS - there is no word in it about 64 bit OSes. I really don't understand.

    Do you mean the options are grayed out precisely because I am on a 64 bit OS? (By the way there are several hundred grayed options, maybe all for different reasons.)

    If so, is there any way Linux could see what Windows sees? 300 MB is no negligible difference.

    I thank everybody who replied, but I am now more confused, than I was before starting this thread.
    Last edited by S0S; 10-07-2010 at 06:36 PM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •