Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all I am using a custom board with at91sam9260 micro controller. I could boot the board successfully with Linux Kernel 2.6.20(customized for our board). And able to 'ping' other ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! sjremya's Avatar
    Join Date
    May 2010
    Location
    India
    Posts
    39

    fails to access embedded board using telnet


    Hi all

    I am using a custom board with at91sam9260 micro controller.

    I could boot the board successfully with Linux Kernel 2.6.20(customized for our board). And able to 'ping' other devices from that.

    When I try to access the same board using telnet from other devices(I use telnet in linux/ putty in windows based machines) , its succeeding for 2-3 hours.But fails after that.
    We are able to access the board through hyper-terminal/minicom, which is connected to the board debug port. Problem is only with telnet connection.

    Is it a kernel bug ? Please help me out to solve this issue.

    Regards

    SJR

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    Since it works for awhile (2-3 hours) I have to think that something unrelated to telnet is going on. Perhaps you inetd/xinetd daemon is failing? When you say if "fails", what EXACTLY do you mean?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •