Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, all. I am Ryoji. I am new to Linux Forums, and I started to use Scientific Linux just recently. And now, I am troubled with booting OS. I think ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Location
    Chiba, Japan
    Posts
    3

    Kernel panic : No init found ........


    Hi, all. I am Ryoji.
    I am new to Linux Forums, and I started to use Scientific Linux just recently.


    And now, I am troubled with booting OS.
    I think Because I removed /lib/tls/libc.so.6 .
    Then, some commands didn't work, and unfortunately I tried to reboot.
    So, I got to watch the error message like this :

    kernel panic : No init found. Try passing init= option to kernel

    Somebodies asked same questions to mine, and got the answer from the wise.
    But it seems not to suit my situation, because now I can not reboot, and cannot command, just watching the screen to select OS. The OS is only scientific linux.

    I seek for the information, but I can solve this problem.
    I hope you tell me some suggestions to solve it. WHAT SHOULD I DO?


    And this is my first post, and I am not good at English. but I never mean I will bother you. I don't wanna bother you.
    Thank you for your kindness.

  2. #2
    Just Joined!
    Join Date
    Mar 2009
    Location
    Norway
    Posts
    67
    I'm not sure why the system would fail to boot just because you remove libc, at least with that error-message you describe here.

    Try setting init=single to see if you can boot into the system that way. At least that will prove that it's not the kernel that's fubar (or the disks..)

    When you see the bootmenu, press 'e' for edit, then 'e' again for the kernel in the next window (second line). Then, move the cursor to the end of the line and add init=single

    then press enter and 'b' to boot.

    Let me know how things go

  3. #3
    Just Joined!
    Join Date
    Jan 2011
    Location
    Chiba, Japan
    Posts
    3
    Thank you for your suggestion, Henrikau

    I tried as you said though, I could not boot again.
    The line that you told me to add "init=single" at the end is like :

    grub edit> kernel /boot/vmlinuz-2.4.21-52.EL ro root=LABEL=/

    and then I added like :

    grub edit> kernel /boot/vmlinuz-2.4.21-52.EL ro root=LABEL=/init=single

    and I pressed "enter" and "b". I met the error massage too. the last 7 lines or this massage were :

    mkrootdev: label /init=single not found
    Mounting root filesystem
    mout: error 2 mounting ext3
    pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
    umount /initrd/proc failed: 2
    Freeing unused kernel memory: 164k freed
    Kernel panic: No init found. Try passing init= option to kernel.

    I hope I could boot again because of you helps.
    Thank you for your kindness.

  4. #4
    Just Joined!
    Join Date
    Mar 2009
    Location
    Norway
    Posts
    67
    The first thing that strikes me, is that it looks like you don't have a space between LABEL=/ and init

    Try a line like so:
    Code:
     kernel /boot/vmlinuz-2.4.21-52.EL ro root=/dev/sda1 init=single ro
    I am assuming that the root-partition is on /dev/sda1, if not, you'll have to change that (to sda2 sda3 or whatever is the correct in your setting)

    UPDATE:
    I just noticed - you're running a 2.4 kernel - you might have to change /dev/sda1 to /dev/hda1 ...

    Or, udate to a 2.6 kernel if that's possible

  5. #5
    Just Joined!
    Join Date
    Jan 2011
    Location
    Chiba, Japan
    Posts
    3
    Hi, Henrikau

    it didn't work well.
    When I wrote :
    Code:
    >kernel /boot/vmlinuz-2.4.21-52.EL ro root=/dev/sda1 init single ro
    and pressed "enter" and "b", then I got the error message :
    Code:
         creating block devices
         creating root device
         Mounting root filesystem
         mount : error 6 mounting ext3
         pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
         umount /initrd/proc failed: 2
         Freeing unused kernle memory: 164k freed
         Kernel panic: No init found. Try passing init= option to kernel.
    When I reworte "/dev/sda1" to "/dev/hda1", it didn't work well too.


    When I wrote :
    Code:
         >kernel /boot/vmlinuz-2.4.21-52.EL ro root=LABEL/ init=single
    then pressed "enter" and "b", I got the error massage :
    Code:
         
         Creating block devices
         Creating root device
         Mounting root filesystem
         kjournald starting. Commit interval 5 seconds
         EXT3-fs: mounted filesystem with ordered data mode.
         Freeing unused kernel memory : 164k freed
         init: relocation error: /lib/i686/libc.so.6: symbol _rtld_global_ro, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
         Kernel panic: Attempted to kill init!
    And when I wrote nothing special and pressed "enter" and "b", it didn't work well too.

    I am totally disappointed ,actually because of my mistake and tiny knowledge.
    Anyway, I still hope I could boot with your great kindness.
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •