Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Upgrading from to 2.6.37 caused kernel panic


    I'm upgrading a kernel of an appliance like device from to 2.6.37 by downloading the official kernels from, doing a "make menuconfig", copying as much of the settings as I can from my old .config, then doing a "make", and making my boot loader(lilo) point to the new kernel.

    This all works. However, when I try to boot the kernel from a Lenovo x201i laptop in compatibility mode(AHCI doesn't even work), I get a kernel panic.

    VFS: Cannot open root device "801" or unknown-block(8,1)
    Please append a correct "root=" boot option; here are the available partitions:
    Kernel panic = not syncing: VFS: Unable to mount root fs on unknown-block(8,1)
    With my old kernel I don't get this.

    I'm guessing I'm missing some SATA drivers, as my lilo "root=" option points to "/dev/sda1", and in compatibility settings the drive might resolve to "/dev/hda1" instead. However, I've looked at the menuconfig settings and I seem to have enabled all available SATA drivers already...does anyone know what I'm missing?


    Edit: I booted up the laptop with a Mandriva Live CD, and a SATA drive connected in both Compatibility and AHCI mode. The drive is detected as /dev/sda in both cases, so it seems like the correct drivers were loaded. an lsmod shows that libata is using ahci and ata_piix.

    I've checked my .config and both AHCI and ATA_PIIX are enabled, so I'm not sure why it isn't booting up correctly...
    Last edited by galapogos; 02-01-2011 at 07:45 AM.

  2. #2

    In addition, is it possible to derive the .config file from the bzImage file? It seems I've lost the old .config file for my kernel, and when I try to make it again, this time I get the same problem as the newer kernel...somewhere somehow some driver isn't being included...

  3. #3
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    NH, USA
    check to make sure you have the sata drivers enabled as at least modules and also check to make sure you have all the filesystems enabled as well (preferably built in to kernel)

  4. $spacer_open
  5. #4
    it seems tht, u dont have valid entry in ur initrd image. Extract the initrd image and check the in it script. It must have all the necessary modules listing in that.

    Extract ur working kernels initrd file and see the init script in that, u will find necessary modules list there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts