Hi,
I'm using 2.6.11 kernel on ARM9. Below are the messages I get issuing different commands.

When I give "reboot" I get run level 6 initiated and get the following messages. I have nothing to complaint about it. All the scripts in rc6.d are executed.

The system is going down for reboot NOW!
INIT: Switching to runlevel: 6
INIT: Sending processes the TERM signal
Terminated
INIT: Sending processes the KILL signal
Unmounting all file systems...
umount: rwfs busy - remounted read-only
umount: rwfs busy - remounted read-only
Rebooting...


When I give "shutdown -now -h", I get following messages. Run level 0 is initiated and all the scripts in rc0.d are executed. No problems here as well.

The system is going down for system halt NOW!
INIT: Switching to runlevel: 0
INIT: Sending processes the TERM signal
Terminated
INIT: Sending processes the KILL signal
Sending all processes the TERM signal...done.
Unmounting all file systems...
umount: rwfs busy - remounted read-only
umount: rwfs busy - remounted read-only


This gets interesting when I pull the auxiliary power line to the board. I would like to know which run level it does initiate. If there are no run levels attached to it, how do i do that? Below are the messages when I get my auxiliary power line pulled out.

The system is going down for reboot NOW!
shutdown: sending all processes the TERM signal...
shutdown: sending all processes the KILL signal.
shutdown: turning off swap
shutdown: unmounting all file systems
umount: /dev: Device or resource busy
Please stand by while rebooting the s