Find the answer to your Linux question:
Results 1 to 2 of 2
I have inserted my network driver module (netdrv.ko). When I try to remove the module using rmmod, it is displaying "killed". When I checked with lsmod, the module is not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Location
    Chennai
    Posts
    15

    Problem in removing network driver module


    I have inserted my network driver module (netdrv.ko). When I try to remove the module using rmmod, it is displaying "killed". When I checked with lsmod, the module is not removed. So, I tried rmmod again, thereby its displaying
    "ERROR: Removing 'netdrv': Device or resource busy"

    I also tried modprobe command(modprobe -rf netdrv). The message shown is
    FATAL: Module netdrv not found.


    How can I remove the module without restarting.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,691
    Since you probably didn't terminate all network services that this module was providing before it was removed, it won't actually be removed (unlinked) until you either shut down all those services/activities, or reboot the system. It is tricky to remove a loaded module. You may unload it, but as you see, it may only be physically removed from the modules directory, but still be in memory and in use.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •