Hello!
I'm download and build default kernel 2.6.38.2.
Then create simple initrd filesystem with busybox and init script .
After install grub on flash and put kernel with initrd on that.
Next reboot and boot from flash I'm give this error:

VFS: Mounted root (ext2 filesystem) readonly on device 1:0
devtmpfs: mounted
Freeing unused kernel memory: 780K freed
Write protecting the kernel read-only data: 10240K
Freeing unused kernel memory: 1704K freed
Freeing unused kernel memory: 1840K freed
Kernel panic - not syncing: No init found. Try passing init+option to kernel

My grub.conf:
. grub.conf
root (hd0,0)
kernel /boot/bzImage ro root=/dev/ram0 ramdisk_size=32768
initrd /boot/initrd.gz

I now that kernel boot the initrd and successfully mounted it but why init script not found?
What I missed?
Thanks a lot for the tips and sorry my bad english.
Alex. Ukraine

PS. One more little question:
How buil 32 bit kernel on 64 bit machine?
In .config option set:
CONFIG_32BIT=y
CONFIG_X86_32=y
CONFIG_X86=y

but builded kernel is 64 bit.