Find the answer to your Linux question:
Results 1 to 9 of 9
hi all i was trying to recompile my kernel with NTFS suport. i tried the following steps cd /usr/src/linux2.4 make clean make menuconfig make dep make bzImage make modules make ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    1

    Kernel panic: no init found. Try passing init= option to ker


    hi all

    i was trying to recompile my kernel with NTFS suport. i tried the following
    steps


    cd /usr/src/linux2.4
    make clean
    make menuconfig
    make dep
    make bzImage
    make modules
    make modules_install
    cp arch/i386/boot/bzImage /boot/vmLinuz-2.4.9
    cd /boot
    /sbin/mkinitrd initrd-2.4.9.img 2.4.9

    added entry of the new kernel to grub.conf and rebooted.
    now i am getting the following errors;

    mounting /proc filesystem
    creating block devices
    mounting root filesystem
    mount : erro 19 mounting exts
    pivotroot : pivot_root (/sysroot, /sysroot/initrd) failed:2
    umount /initrd/proc failed :2
    freeing unused kernel memory : 128k freed
    Kernel panic: no init found. Try passing init= option to kernel


    can anyone help me. i am in deep trouble.

  2. #2
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    As the error says: pass a init level to the kernel. Assuming you have grub open up /boot/grub/menu.1st and add 'init=3' to the options in the config like:
    Code:
    kernel (hd0,0)/boot/linux-2.6.8 root=/dev/hda1 idebus=66 init=3
    Best way to do that would be to use a livecd like the gentoo cd. Good luck.
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    1
    Quote Originally Posted by gwalters
    As the error says: pass a init level to the kernel. Assuming you have grub open up /boot/grub/menu.1st and add 'init=3' to the options in the config like:
    Code:
    kernel (hd0,0)/boot/linux-2.6.8 root=/dev/hda1 idebus=66 init=3
    Best way to do that would be to use a livecd like the gentoo cd. Good luck.
    What does this "idebus=66 init=3" mean?
    Are they mandatory? or optional?

  4. #4
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    the 'idebus=66' is optional, its just an option i forgot to remove for the post. the 'init=3' in NOT optional. it is the bit thats solving your problem.

    "Kernel panic: no init found. Try passing init= option to kernel "

    by 'init=3' we are passing an init= option to the kernel
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1
    i'm having the same issue but with lilo, what is the name of the file for lilo

  6. #6
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Quote Originally Posted by maybe2077
    i'm having the same issue but with lilo, what is the name of the file for lilo
    /etc/lilo.conf

    Remember to run /sbin/lilo after you edit your lilo.conf.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  7. #7
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    You don't need to a LiveCD for Grub, it has built-in editing (unlike LILO). Just press 'e' for edit. I don't think that makes the changes permanent, so once you're booted, make sure to change them permanently by editing the file.
    Emotions are the key to the soul.
    Registered Linux User #375050

  8. #8
    Just Joined!
    Join Date
    Jun 2005
    Posts
    1
    i get that message al the time now, the first time i got my hands on mandrake 10.1 i installed it on a parition and everything wen't great, i rebooted, selected linux from the graphic lilo menu, and bam it smacked me with - Kernel panic: No init found. Try passing init= option to kernel
    aaaaa i cried i don't mean to sound thick but i didn't really understand the passing option to kernal thingy, without being to blunt...what do i do to fix it??
    thanks in advance
    a1eio

    EDIT: I Think i get it now, i'll just go try it

  9. #9
    Just Joined!
    Join Date
    Jul 2007
    Posts
    7

    init paramater crashed my mandriva bootup - used rhbg instead

    Hi,

    This might be slightly off topic. But when I tried to add a init parameter to my grub file mandriva linux wouldn't load - crashed on boot with a kernel panic really didn't like that init parameter.

    I originally wanted to control run levels via grub menus.

    I then found I could do this -

    kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 resume=/dev/hda5 splash=silent vga=788 rhgb quiet X

    X being the run level. Now I can boot up on either run level 3 or 5 with two meu entries.

    I don't understand how this fixed it but it did. Now I have to work backwards and understand how rhgb overrides my /etc/inittab file. And what the heck quiet means.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •