Find the answer to your Linux question:
Results 1 to 2 of 2
Hi guys, Kernel newbie here. For the better part of this day, I've been trying to compile and run linux 2.6.39.2. There were a ton of issues along the way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    2

    mount: mounting none on /dev failed


    Hi guys,

    Kernel newbie here. For the better part of this day, I've been trying to compile and run linux 2.6.39.2. There were a ton of issues along the way so I tried to follow the instructions from a lot of places, but mostly I used those in the book "Essential Linux Device Drivers" and those provided here: cyberciti.biz/tips/compiling-linux-kernel-26.html (forum says I'm not mature enough to post urls to other sites, sorry )
    I elliminated a lot of problems, but now I just have to ask you about one I've been trying to figure out for hours:
    1. I've compiled both kernel and modules, and installed them, created an initrd (thought with initramfs, I'm using Ubuntu 10.04).
    2.I've added an entry to my 1.98 GRUB loader in the 40_custom file.
    3.When booting my machine, I attempt to run said entry, then for only an instant a console with the errors I get flashes, followed by a Ubuntu load screen, and then switched back to.
    It is a initramfs> console, and at the top it says something along the lines of:
    mount: mounting none on /dev failed: No such device.
    ALERT! /dev/disk/by-uuid/*the actually very id that can't be found* does not exist
    I've been googling for hours, so I'd better list some of the things I've tried and haven't worked:
    - I can't edit /etc/fstab because I have no such file.
    - I can't mount sda5 (that's where my linux source resides), because the closest to it in my /dev folder is /dev/sda, and that says it can't be mounted or something like that.
    - I have triple checked the UUID and it is the correct one.
    - in my /disk folder I just don't have a by-uuid folder, only by-id(I think) and by-path folders.

    Sorry for the long post, but I wanted to be as clear as possible.

    Thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Jul 2011
    Posts
    2
    Anyone, anything?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •