Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi all, I want to build and boot an own kernel (v.2.6.39.4). But i got an kernel panic while booting the new kernel: Code: Failed to execute /bin/bash. Attempting defaults ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2011
    Posts
    5

    Exclamation Kernel panic


    Hi all,

    I want to build and boot an own kernel (v.2.6.39.4). But i got an kernel panic while booting the new kernel:

    Code:
    Failed to execute /bin/bash. Attempting defaults
    Kernel panic - not syncing: No init found. Try passing init= option to kernel. See linux documentation/init.txt for guidance
    Pid: 1, comm: swapper Not tainted 3.0.0 #1
    Can anyone help me out?
    Last edited by sentmen; 08-07-2011 at 01:10 PM. Reason: kernel version

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,517
    1. What was the old kernel?
    2. How did you build and install the new kernel?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Aug 2011
    Posts
    5
    Quote Originally Posted by Rubberman View Post
    1. What was the old kernel?
    2. How did you build and install the new kernel?
    1. I want to make a own distribution. I used the last version of debian 6 (netinstall)
    2. From an tutorial. Edited not much in make menuconfig

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,517
    Quote Originally Posted by sentmen View Post
    1. I want to make a own distribution. I used the last version of debian 6 (netinstall)
    2. From an tutorial. Edited not much in make menuconfig
    Please show the exact steps from "make menuconfig" to "make install". Also, did you get any error messages when installing the kernel?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Aug 2011
    Posts
    5
    Sometimes if i look at the screen i get with some files errors (or warnings) but it don't stop with compiling. I tried it on more devices. And also in an virtual machine. I tried ubuntu and debian. The exact steps including what i used in the menuconfig?

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,517
    Quote Originally Posted by sentmen View Post
    Sometimes if i look at the screen i get with some files errors (or warnings) but it don't stop with compiling. I tried it on more devices. And also in an virtual machine. I tried ubuntu and debian. The exact steps including what i used in the menuconfig?
    Your problem is not likely due to changes made with menuconfig, but how you built and installed the kernel. IE:

    make menuconfig
    make
    make headers_install
    make modules_install
    make install

    and any errors (warnings are not at issue at this point) you got while doing the above.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    Jul 2011
    Posts
    16
    In your case the kernel is booted up normally, I think it is not able to mount the root file system correctly, where the init executable file is stored. Do one thing, boot up the system with the working kernel and use mount command to find out which is the root file system. The one which is mounted on /. Say, for example, that is /dev/sda2. While booting the system with new kernel specify /dev/sda2 as root file system partion, using the root option at grup menu.
    Last edited by oz; 08-09-2011 at 03:37 PM. Reason: removed spam redirect

  8. #8
    Just Joined!
    Join Date
    Aug 2011
    Posts
    5
    Quote Originally Posted by rulingminds View Post
    In your case the kernel is booted up normally, I think it is not able to mount the root file system correctly, where the init executable file is stored. Do one thing, boot up the system with the working kernel and use mount command to find out which is the root file system. The one which is mounted on /. Say, for example, that is /dev/sda2. While booting the system with new kernel specify /dev/sda2 as root file system partion, using the root option at grup menu.
    Yes. It is exactly what the problem is. Let me show my grub item.

    Code:
    menuentry 'sentmen' {
    set root='(hd1,1)'
    linux /boot/vmlinuz root=/dev/sdb1 ro
    }

  9. #9
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Your original post shows "No init found". Your grub menuentry has no initrd line. That's the problem. Do you have an initrd file on sdb1.
    I don't really know the solution, maybe re-read the tutorial you used?

  10. #10
    Just Joined!
    Join Date
    Aug 2011
    Posts
    5
    Quote Originally Posted by yancek View Post
    Your original post shows "No init found". Your grub menuentry has no initrd line. That's the problem. Do you have an initrd file on sdb1.
    I don't really know the solution, maybe re-read the tutorial you used?
    I don't have an initrd created. But if i do that it will be used for debian. And i don't want that.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •