Find the answer to your Linux question:
Results 1 to 2 of 2
Hello Linux Forums. I am new to the website so please feel free to move this or merge this with any existing thread if you see fit but I didnt ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2011
    Posts
    1

    Fedora 15 Kernel Panic


    Hello Linux Forums. I am new to the website so please feel free to move this or merge this with any existing thread if you see fit but I didnt want to hijack another thread.

    I have recently installed Fedora 15 onto a Dell inspiron 630m. Before the install I had put in new ram and was using natty narwale. Natty worked fine with the new ram and so did fedora until I got this error every time I would boot:

    Code:
    [    1.459417] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
    [    1.459472] Pid: 1, comm: swapper Not tainted 2.6.40.3-0.fc15.i686 #1
    [    1.459517] Call Trace:
    [    1.459560]   [<c07e242a>] ? printk+0x2d/0x2f
    [    1.459602]   [<c07e2303>] panic+0x5c/0x156
    [    1.459646]   [<c0a84b7f>] mount_block_root+0x218/0x238
    [    1.459693]   [<c04f5ba4>] ? sys_mknod+0x2c/0x2e
    [    1.459735]   [<c0a84b7f>] mount_root+0x59/0x5f
    [    1.459778]   [<c0a84e6b>] prepare_namespace+0x14e/0x192
    [    1.459822]   [<c04ea7ab?] ? sys_access+0x25/0x27
    [    1.459865]   [<c0a848ae>] kernel_init+0x131/0x136
    [    1.459908]   [<c0a8477d>] ? start_kernel+0x353/0x353
    [    1.459952]   [<c07efd7e>] kernel_thread_helper+0x6/0x10
    I feel like the kernel panic type error would be the same through most linux distros because its all in the kernel but I may be off on that.

    Do any of you have any experience with a kernel panic or how to fix one? Any info would be awesome and I would definitely appreciate any posts that can help me out. I literally have no idea what to do so if someone can help me I may need a bit more of a simpler explanation on how to do things.

    A little more information: I had xp on this computer previously but then put on ubuntu natty narwhale and hated that so I put on fedora 15.
    I put in more ram prior to the natty narwhale install and it worked fine.
    I used terminal to install vlc.
    I tried to use the terminal to install flash but it would not work and kept getting an error.
    I shutdown the computer from terminal but canceled the shutdown process twice then finally shut it down the third time.

    I dont know if any of this will help but I feel the more info I get to you guys the more I can find out how to fix this jazz.

  2. #2
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    Hi -

    You mentioned that F15 worked with new RAM. Did you do any change after it was working fine?

    Looks like invalid device being used for root-fs. Can you post grub conf here?
    ---------------------------------
    Registered Linux User #440311
    HI2ARUN _AT_ GMAIL _DOT_ COM
    ---------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •