My objective is to Update new kernel...After compile kernel ....my Ethernet port is not working

why i am confuse because my two Ethernet port module load in e1000 and others are loaded in e1000e


Code:
Linux version 2.6.39.4-1smp (root@localhost.localdomain) (gcc version 4.4.1 20090725 (Red Hat 4.4.1-2) (GCC) ) #3 SMP Sat Nov 5 20:26:40 IST 2011
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f400 (usable)
 BIOS-e820: 000000000009f400 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000007f690000 (usable)
 BIOS-e820: 000000007f690000 - 000000007f700000 (reserved)
 BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
 BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
Notice: NX (Execute Disable) protection cannot be enabled: non-PAE kernel!
DMI 2.2 present.
last_pfn = 0x7f690 max_arch_pfn = 0x100000
x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
found SMP MP-table at [c00f34c0] f34c0
init_memory_mapping: 0000000000000000-00000000377fe000
RAMDISK: 00fd1000 - 01000000
1150MB HIGHMEM available.
887MB LOWMEM available.
  mapped low ram: 0 - 377fe000
  low ram: 0 - 377fe000
Zone PFN ranges:
  DMA      0x00000010 -> 0x00001000
  Normal   0x00001000 -> 0x000377fe
  HighMem  0x000377fe -> 0x0007f690
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
    0: 0x00000010 -> 0x0000009f
    0: 0x00000100 -> 0x0007f690
Using APIC driver default
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
MPTABLE: OEM ID: OEM00000
MPTABLE: Product ID: PROD00000000
MPTABLE: APIC at: 0xFEE00000
Processor #0 (Bootup-CPU)
Processor #1
IOAPIC[0]: apic_id 4, version 32, address 0xfec00000, GSI 0-23
Processors: 2
SMP: Allowing 2 CPUs, 0 hotplug CPUs
Allocating PCI resources starting at 7f700000 (gap: 7f700000:60900000)
setup_percpu: NR_CPUS:8 nr_cpumask_bits:8 nr_cpu_ids:2 nr_node_ids:1
PERCPU: Embedded 12 pages/cpu @f6400000 s24832 r0 d24320 u2097152
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 517681
Kernel command line: BOOT_IMAGE=linux4 ro root=806 BOOT_FILE=/boot/vmlinuz-2.6.39.4-1smp console=ttyS0 console=tty0
PID hash table entries: 4096 (order: 2, 16384 bytes)
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Initializing CPU#0
Initializing HighMem for node 0 (000377fe:0007f690)
Memory: 2065900k/2087488k available (2175k kernel code, 21136k reserved, 971k data, 292k init, 1178184k highmem)
virtual kernel memory layout:
    fixmap  : 0xfff18000 - 0xfffff000   ( 924 kB)
    pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
    vmalloc : 0xf7ffe000 - 0xff7fe000   ( 120 MB)
    lowmem  : 0xc0000000 - 0xf77fe000   ( 887 MB)
      .init : 0xc1313000 - 0xc135c000   ( 292 kB)
      .data : 0xc121fcca - 0xc1312b00   ( 971 kB)
      .text : 0xc1000000 - 0xc121fcca   (2175 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
Hierarchical RCU implementation.
NR_IRQS:512
Console: colour VGA+ 80x25
console [tty0] enabled
console [ttyS0] enabled
Fast TSC calibration using PIT
Detected 1795.101 MHz processor.
Calibrating delay loop (skipped), value calculated using timer frequency.. 3590.20 BogoMIPS (lpj=7180404)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
mce: CPU supports 6 MCE banks
CPU0: Thermal monitoring enabled (TM1)
using mwait in idle threads.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
ExtINT not setup in hardware but reported by MP table
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=0 pin2=0
CPU0: Intel(R) Core(TM)2 CPU          4300  @ 1.80GHz stepping 02
Performance Events: PEBS fmt0-, Core2 events, Intel PMU driver.
PEBS disabled due to CPU errata.
... version:                2
... bit width:              40
... generic registers:      2
... value mask:             000000ffffffffff
... max period:             000000007fffffff
... fixed-purpose events:   3
... event mask:             0000000700000003
Booting Node   0, Processors  #1 Ok.
Initializing CPU#1
Brought up 2 CPUs
Total of 2 processors activated (7181.49 BogoMIPS).
NET: Registered protocol family 16
PCI: PCI BIOS revision 3.00 entry at 0xf9420, last bus=5
PCI: Using configuration type 1 for base access
bio: create slab <bio-0> at 0
vgaarb: loaded
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Probing PCI hardware
pci 0000:00:1f.0: ICH7 LPC Generic IO decode 1 PIO at 4700 (mask 000f)
pci 0000:00:1f.0: ICH7 LPC Generic IO decode 2 PIO at 0280 (mask 003f)
pci 0000:01:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
pci 0000:00:1c.0: PCI bridge to [bus 01-01]
pci 0000:02:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
pci 0000:00:1c.1: PCI bridge to [bus 02-02]
pci 0000:03:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
pci 0000:00:1c.2: PCI bridge to [bus 03-03]
pci 0000:04:00.0: disabling ASPM on pre-1.1 PCIe device.  You can enable it with 'pcie_aspm=force'
pci 0000:00:1c.3: PCI bridge to [bus 04-04]
pci 0000:00:1e.0: PCI bridge to [bus 05-05] (subtractive decode)
vgaarb: device added: PCI:0000:00:02.0,decodes=io+mem,owns=io+mem,locks=none
HPET: 3 timers in total, 0 timers will be used for per-cpu timer
Switching to clocksource hpet
pci 0000:00:1c.0: PCI bridge to [bus 01-01]
pci 0000:00:1c.0:   bridge window [io  0xb000-0xbfff]
pci 0000:00:1c.0:   bridge window [mem 0xfd700000-0xfd7fffff]
pci 0000:00:1c.0:   bridge window [mem 0xfde00000-0xfdefffff 64bit pref]
pci 0000:00:1c.1: PCI bridge to [bus 02-02]
pci 0000:00:1c.1:   bridge window [io  0xa000-0xafff]
pci 0000:00:1c.1:   bridge window [mem 0xfdd00000-0xfddfffff]
pci 0000:00:1c.1:   bridge window [mem 0xfdc00000-0xfdcfffff 64bit pref]
pci 0000:00:1c.2: PCI bridge to [bus 03-03]
pci 0000:00:1c.2:   bridge window [io  0xe000-0xefff]
pci 0000:00:1c.2:   bridge window [mem 0xfdb00000-0xfdbfffff]
pci 0000:00:1c.2:   bridge window [mem 0xfda00000-0xfdafffff 64bit pref]
pci 0000:00:1c.3: PCI bridge to [bus 04-04]
pci 0000:00:1c.3:   bridge window [io  0xd000-0xdfff]
pci 0000:00:1c.3:   bridge window [mem 0xfd900000-0xfd9fffff]
pci 0000:00:1c.3:   bridge window [mem 0xfd800000-0xfd8fffff 64bit pref]
pci 0000:05:07.0: BAR 6: assigned [mem 0xfd500000-0xfd50ffff pref]
pci 0000:05:0a.0: BAR 6: assigned [mem 0xfd510000-0xfd51ffff pref]
pci 0000:00:1e.0: PCI bridge to [bus 05-05]
pci 0000:00:1e.0:   bridge window [io  0xc000-0xcfff]
pci 0000:00:1e.0:   bridge window [mem 0xfd600000-0xfd6fffff]
pci 0000:00:1e.0:   bridge window [mem 0xfd500000-0xfd5fffff 64bit pref]
pci 0000:00:1c.0: PCI->APIC IRQ transform: INT A -> IRQ 16
pci 0000:00:1c.1: PCI->APIC IRQ transform: INT B -> IRQ 17
pci 0000:00:1c.2: PCI->APIC IRQ transform: INT C -> IRQ 18
pci 0000:00:1c.3: PCI->APIC IRQ transform: INT D -> IRQ 19
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
UDP hash table entries: 512 (order: 2, 16384 bytes)
UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
NET: Registered protocol family 1
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 188k freed
platform rtc_cmos: registered platform RTC device (no PNP device found)
highmem bounce pool size: 64 pages
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
msgmni has been set to 1734
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
brd: module loaded
Uniform Multi-Platform E-IDE driver
piix 0000:00:1f.1: IDE controller (0x8086:0x27df rev 0x01)
pci 0000:00:1f.1: PCI->APIC IRQ transform: INT A -> IRQ 16
piix 0000:00:1f.1: IDE port disabled
piix 0000:00:1f.1: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfa00-0xfa07
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide_generic: please use "probe_mask=0x3f" module parameter for probing all legacy ISA IDE ports
ide-gd driver 1.18
ata_piix 0000:00:1f.2: PCI->APIC IRQ transform: INT B -> IRQ 19
ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
scsi0 : ata_piix
scsi1 : ata_piix
ata1: SATA max UDMA/133 cmd 0xf900 ctl 0xf800 bmdma 0xf500 irq 19
ata2: SATA max UDMA/133 cmd 0xf700 ctl 0xf600 bmdma 0xf508 irq 19
e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
e1000: Copyright (c) 1999-2006 Intel Corporation.
e1000 0000:05:07.0: PCI->APIC IRQ transform: INT A -> IRQ 23
ata2.01: ATA-8: ST3250312AS, JC45, max UDMA/133
ata2.01: 488397168 sectors, multi 16: LBA48 NCQ (depth 0/32)
Refined TSC clocksource calibration: 1795.499 MHz.
Switching to clocksource tsc
ata2.01: configured for UDMA/133
scsi 1:0:1:0: Direct-Access     ATA      ST3250312AS      JC45 PQ: 0 ANSI: 5
sd 1:0:1:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)
sd 1:0:1:0: Attached scsi generic sg0 type 0
sd 1:0:1:0: [sda] Write Protect is off
sd 1:0:1:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
e1000 0000:05:07.0: eth0: (PCI:33MHz:32-bit) 00:02:b6:41:fc:55
 sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 >
e1000 0000:05:07.0: eth0: Intel(R) PRO/1000 Network Connection
sd 1:0:1:0: [sda] Attached SCSI disk
e1000 0000:05:0a.0: PCI->APIC IRQ transform: INT A -> IRQ 20
e1000 0000:05:0a.0: eth1: (PCI:33MHz:32-bit) 00:02:b6:41:fc:56
e1000 0000:05:0a.0: eth1: Intel(R) PRO/1000 Network Connection
e1000e: Intel(R) PRO/1000 Network Driver - 1.3.10-k2
e1000e: Copyright(c) 1999 - 2011 Intel Corporation.
e1000e 0000:01:00.0: Disabling ASPM  L1
e1000e 0000:01:00.0: PCI->APIC IRQ transform: INT A -> IRQ 16
e1000e 0000:01:00.0: Disabling ASPM L0s 
e1000e 0000:01:00.0: eth2: (PCI Express:2.5GB/s:Width x1) 00:02:b6:41:fc:51
e1000e 0000:01:00.0: eth2: Intel(R) PRO/1000 Network Connection
e1000e 0000:01:00.0: eth2: MAC: 2, PHY: 2, PBA No: FFFFFF-0FF
e1000e 0000:02:00.0: Disabling ASPM  L1
e1000e 0000:02:00.0: PCI->APIC IRQ transform: INT A -> IRQ 17
e1000e 0000:02:00.0: Disabling ASPM L0s 
e1000e 0000:02:00.0: eth3: (PCI Express:2.5GB/s:Width x1) 00:02:b6:41:fc:52
e1000e 0000:02:00.0: eth3: Intel(R) PRO/1000 Network Connection
e1000e 0000:02:00.0: eth3: MAC: 2, PHY: 2, PBA No: FFFFFF-0FF
e1000e 0000:03:00.0: Disabling ASPM  L1
e1000e 0000:03:00.0: PCI->APIC IRQ transform: INT A -> IRQ 18
e1000e 0000:03:00.0: Disabling ASPM L0s 
e1000e 0000:03:00.0: eth4: (PCI Express:2.5GB/s:Width x1) 00:02:b6:41:fc:53
e1000e 0000:03:00.0: eth4: Intel(R) PRO/1000 Network Connection
e1000e 0000:03:00.0: eth4: MAC: 2, PHY: 2, PBA No: FFFFFF-0FF
e1000e 0000:04:00.0: Disabling ASPM  L1
e1000e 0000:04:00.0: PCI->APIC IRQ transform: INT A -> IRQ 19
e1000e 0000:04:00.0: Disabling ASPM L0s 
e1000e 0000:04:00.0: eth5: (PCI Express:2.5GB/s:Width x1) 00:02:b6:41:fc:54
e1000e 0000:04:00.0: eth5: Intel(R) PRO/1000 Network Connection
e1000e 0000:04:00.0: eth5: MAC: 2, PHY: 2, PBA No: FFFFFF-0FF
usbmon: debugfs is not available
serio: i8042 KBD port at 0x60,0x64 irq 1
mousedev: PS/2 mouse device common for all mice
TCP bic registered
Using IPI No-Shortcut mode
Freeing unused kernel memory: 292k freed
EXT3-fs: barriers not enabled
kjournald starting.  Commit interval 5 seconds
EXT3-fs (sda6): mounted filesystem with ordered data mode

when i am trying to insert a module its give fatal error..

Code:
[root@manage /root]# modprobe e1000
FATAL: Error inserting e1000 (/lib/modules/2.6.39.4-1smp/kernel/drivers/net/e1000/e1000.ko): Invalid argument
[root@manage /root]# modprobe e1000e
FATAL: Error inserting e1000e (/lib/modules/2.6.39.4-1smp/kernel/drivers/net/e1000e/e1000e.ko): Invalid argument
[root@manage /root]#


Please Suggest me how to Solve this problem.....