Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, I am compiling a real-time linux kernel (2.6.31.12-rt) for my xilinx board. I got Kernel panic as below: ...... [ 4.712000] Freeing unused kernel memory: 7346k freed [ ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    2

    Kernel panic with Warning "tty_release_dev"


    Hi all,

    I am compiling a real-time linux kernel (2.6.31.12-rt) for my xilinx board. I got Kernel panic as below:

    ......
    [ 4.712000] Freeing unused kernel memory: 7346k freed
    [ 4.740000] Warning: dev (ttyS0) tty->count(1) != #fd's(0) in tty_release_dev
    [ 4.748000] Kernel panic - not syncing: Attempted to kill init!
    [ 4.756000] Rebooting in 120 seconds..
    [ 128.792000] Machine restart...
    [ 128.796000]
    [ 128.796000] Stack:
    [ 128.796000] d7835a68 00000000 00000000 00000000 d7835a84 d002fe38 d018b948 de610000
    [ 128.808000] 00000001 00000000 00003ffc 00000000 d001c52c d001c4d0 800045a4 0001d4bf
    [ 128.816000] 00000000 00000000 0000000b d00206dc d018e820 00000078 00000000 ffffffff
    [ 128.824000] Call Trace:
    [ 128.824000] ....
    ....

    I am not sure if it is the "Warning" caused the panic, can someone help me please?

    Thanks in advance!

    Best regards,
    sf

  2. #2
    Just Joined!
    Join Date
    Mar 2011
    Posts
    68
    Do you by chance have debug logging enabled in udev?
    Either by booting off an older working kernel or mounting this file system under another working system, run this:
    Code:
    grep udev_log /etc/udev/udev.conf
    and if it comes back with a udev_log="debug" you will need to edit the file with your favorite editor and replace "debug" with "err"

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    2
    Quote Originally Posted by bleedingsamurai View Post
    Do you by chance have debug logging enabled in udev?
    Either by booting off an older working kernel or mounting this file system under another working system, run this:
    Code:
    grep udev_log /etc/udev/udev.conf
    and if it comes back with a udev_log="debug" you will need to edit the file with your favorite editor and replace "debug" with "err"
    Hi bleedingsamurai,

    Thank you for the reply! In my case, it is almost not possible to touch the files on the board (isolated files ..) unless the board can be boot up.

    The warning itself is not an issue of boot-up failure, it disappeared after I changed the number of ttys in device driver. I am doubting about my rootfs, it seems nothing has been mounted.

    Thanks anyway for your reply! !

    Best regards,
    sf

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •